summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjan.reininghaus <jan.reininghaus@8e3bb3c2-eed4-f18f-5264-0b6c94e6926d>2013-05-07 13:47:24 +0000
committerjan.reininghaus <jan.reininghaus@8e3bb3c2-eed4-f18f-5264-0b6c94e6926d>2013-05-07 13:47:24 +0000
commit6377a0044f16f987c3d32cabeadf393eb6f17088 (patch)
treeb6f4ecf0adb3c9bf82c3698e7f17ae41a290dceb
parent6f348338736b4f7c4386e4034f78ad8286417965 (diff)
update CMakeLists.txt to give a nice name to the Makefile
git-svn-id: https://phat.googlecode.com/svn/trunk@66 8e3bb3c2-eed4-f18f-5264-0b6c94e6926d
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd6ffe8..62b0584 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,7 @@
cmake_minimum_required(VERSION 2.8)
+project("Phat")
+
set(CMAKE_BUILD_TYPE "Release")
INCLUDE(CheckCXXSourceCompiles)
@@ -40,9 +42,9 @@ endif()
FILE(GLOB_RECURSE all_headers "include/phat/*.h")
FILE(GLOB general_includes "include/phat/*.h")
-FILE(GLOB algorithms_includes "include/phat/*.h")
-FILE(GLOB helpers_includes "include/phat/*.h")
-FILE(GLOB representations_includes "include/phat/*.h")
+FILE(GLOB algorithms_includes "include/phat/algorithms/*.h")
+FILE(GLOB helpers_includes "include/phat/helpers/*.h")
+FILE(GLOB representations_includes "include/phat/representations/*.h")
add_executable (simple_example src/simple_example.cpp ${all_headers})
add_executable (self_test src/self_test.cpp ${all_headers})