summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorulrich.bauer@gmail.com <ulrich.bauer@gmail.com@8e3bb3c2-eed4-f18f-5264-0b6c94e6926d>2013-04-30 09:24:16 +0000
committerulrich.bauer@gmail.com <ulrich.bauer@gmail.com@8e3bb3c2-eed4-f18f-5264-0b6c94e6926d>2013-04-30 09:24:16 +0000
commitfde6d0e49fc93d86fd50143e50c3c11f11440712 (patch)
tree7fb03e6f8c0f68b21d18f508bb2c963c692896bc
parent204f8ace0554cb8290a7f8cfca947d4a1251f985 (diff)
rolled back changes
git-svn-id: https://phat.googlecode.com/svn/trunk@51 8e3bb3c2-eed4-f18f-5264-0b6c94e6926d
-rw-r--r--CMakeLists.txt22
-rw-r--r--include/phat/compute_persistence_pairs.h16
2 files changed, 0 insertions, 38 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 923a069..98ffc17 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,6 @@ set(CMAKE_BUILD_TYPE "Release")
INCLUDE(CheckCXXSourceCompiles)
include_directories (include)
-include_directories (/opt/local/include)
FIND_PACKAGE(OpenMP)
@@ -39,24 +38,3 @@ endif()
add_executable (simple_example src/simple_example.cpp)
add_executable (self_test src/self_test.cpp)
add_executable (phat src/phat.cpp)
-add_executable (reduction_test reduction_test.cpp)
-add_executable (benchmark src/benchmark.cpp)
-
-
-set(CMAKE_MODULE_PATH "modules")
-set(CGAL_DIR "/opt/local/lib/cmake")
-
-FIND_PACKAGE(CGAL)
-
-if ( CGAL_FOUND )
-
- include( ${CGAL_USE_FILE} )
-else()
-
- message(STATUS "This program requires the CGAL library, and will not be compiled.")
-
-endif()
-
-FIND_PACKAGE(Boost)
-
-add_executable (alpha_3 addons/alpha_3.cpp)
diff --git a/include/phat/compute_persistence_pairs.h b/include/phat/compute_persistence_pairs.h
index ca46ac0..e782bd7 100644
--- a/include/phat/compute_persistence_pairs.h
+++ b/include/phat/compute_persistence_pairs.h
@@ -43,24 +43,8 @@ namespace phat {
void compute_persistence_pairs_dualized( persistence_pairs& pairs, boundary_matrix< Representation >& boundary_matrix ) {
ReductionAlgorithm reduce;
const index nr_columns = boundary_matrix.get_num_cols();
-
- double start;
-
- start= omp_get_wtime();
- std::clog << "Dualize ... " << std::endl;
-
dualize( boundary_matrix );
-
- std::clog << omp_get_wtime() - start <<"s" << std::endl;
-
- start= omp_get_wtime();
- std::clog << "Reduce ... " << std::endl;
-
reduce( boundary_matrix );
-
- std::clog << omp_get_wtime() - start <<"s" << std::endl;
-
-
pairs.clear();
for( index idx = 0; idx < nr_columns; idx++ ) {
if( !boundary_matrix.is_empty( idx ) ) {