summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2019-02-19 15:26:56 +0100
committerGard Spreemann <gspreemann@gmail.com>2019-02-19 17:01:48 +0100
commitcfd80cdf5c36a77e9f17ad1c7c56173bba90c710 (patch)
treec7394016bdda37b5324beed461c35ce8d81589a3 /debian/rules
parentfc0ba52e7d32d8fe48b3b7abfc9b1cc5ce315144 (diff)
Build Python interface.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index ddd8443..d923eef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,12 @@
#export DH_VERBOSE = 1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export PYBUILD_NAME = phat
+
+# To avoid autodetecting upstream's CMakeFile, which doesn't build the
+# Python extension.
+export PYBUILD_SYSTEM = distutils
%:
dh $@ --buildsystem=cmake --builddirectory=build
+ dh $@ --with python3 --buildsystem=pybuild