summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Amici <a.amici@bopen.eu>2018-05-10 17:13:34 +0200
committerAlessandro Amici <a.amici@bopen.eu>2018-05-10 17:13:34 +0200
commit97385c7b72e2e7fd2d7d61fb9a381f4b4c2744c7 (patch)
tree921d6b57e0a277dd201a0aca569c99a1c58c5aa5
parentd552b06350934d7c5c65b6c69e54b1c5a6db49a1 (diff)
Minimal and untested README.rst.
-rw-r--r--README.rst25
-rw-r--r--setup.py2
2 files changed, 25 insertions, 2 deletions
diff --git a/README.rst b/README.rst
index 0db68d7..0be3bba 100644
--- a/README.rst
+++ b/README.rst
@@ -1 +1,24 @@
-Todo
+
+Install
+-------
+
+Install via `pip` with::
+
+ $ pip install cdsapi
+
+
+Configure
+---------
+
+Get your API key from the CDS portal and write it into the configuration file::
+
+ $ vim ~/.cdsapi
+
+Test
+----
+
+ $ python
+ >>> import cdsapi
+ >>> cds = cdsapi.Client()
+ >>> cds.get_resource("insitu-glaciers-extent", {})
+ ...
diff --git a/setup.py b/setup.py
index d6cf052..578ee59 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ setuptools.setup(
author='ECMWF',
author_email='software@ecmwf.int',
license='Apache 2.0',
- url='https://software.ecmwf.int/stash/projects/CST/repos/cdscompute',
+ url='https://software.ecmwf.int/stash/projects/CST/repos/cdsapi',
description="Climate Data Store API",
long_description=read('README.rst'),
packages=setuptools.find_packages(),