summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-06-13 10:27:28 +0200
committerGard Spreemann <gspr@nonempty.org>2020-06-13 10:27:28 +0200
commit127331bfa39c411d4994aadf0d3e1bb973575239 (patch)
treeffdd64c48b3ce1bbc4672b331dd8b9e4fe77b2b3
parent87031d3c36c2830586054ed706b1a28bd7e5c43f (diff)
Upstream 0.2.9 tarball as released on PyPI.upstream/0.2.9
-rw-r--r--PKG-INFO2
-rw-r--r--cdsapi.egg-info/PKG-INFO2
-rw-r--r--cdsapi.egg-info/SOURCES.txt1
-rwxr-xr-xexample-era5-update.py47
-rw-r--r--setup.py2
5 files changed, 3 insertions, 51 deletions
diff --git a/PKG-INFO b/PKG-INFO
index ab34266..30e252e 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: cdsapi
-Version: 0.2.8
+Version: 0.2.9
Summary: Climate Data Store API
Home-page: https://software.ecmwf.int/stash/projects/CDS/repos/cdsapi
Author: ECMWF
diff --git a/cdsapi.egg-info/PKG-INFO b/cdsapi.egg-info/PKG-INFO
index ab34266..30e252e 100644
--- a/cdsapi.egg-info/PKG-INFO
+++ b/cdsapi.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: cdsapi
-Version: 0.2.8
+Version: 0.2.9
Summary: Climate Data Store API
Home-page: https://software.ecmwf.int/stash/projects/CDS/repos/cdsapi
Author: ECMWF
diff --git a/cdsapi.egg-info/SOURCES.txt b/cdsapi.egg-info/SOURCES.txt
index 8c59e21..cbd1fce 100644
--- a/cdsapi.egg-info/SOURCES.txt
+++ b/cdsapi.egg-info/SOURCES.txt
@@ -2,7 +2,6 @@ CONTRIBUTING.rst
LICENSE.txt
MANIFEST.in
README.rst
-example-era5-update.py
example-era5.py
example-glaciers.py
setup.cfg
diff --git a/example-era5-update.py b/example-era5-update.py
deleted file mode 100755
index 5749e84..0000000
--- a/example-era5-update.py
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/usr/bin/env python
-
-# (C) Copyright 2018 ECMWF.
-#
-# This software is licensed under the terms of the Apache Licence Version 2.0
-# which can be obtained at http://www.apache.org/licenses/LICENSE-2.0.
-# In applying this licence, ECMWF does not waive the privileges and immunities
-# granted to it by virtue of its status as an intergovernmental organisation nor
-# does it submit to any jurisdiction.
-
-import time
-import cdsapi
-
-c = cdsapi.Client(debug=True, wait_until_complete=False)
-
-r = c.retrieve(
- "reanalysis-era5-single-levels",
- {
- "variable": "2t",
- "product_type": "reanalysis",
- "date": "2015-12-01",
- "time": "14:00",
- "format": "netcdf",
- },
-)
-
-sleep = 30
-while True:
- r.update()
- reply = r.reply
- r.info("Request ID: %s, state: %s" % (reply['request_id'], reply['state']))
-
- if reply['state'] == 'completed':
- break
- elif reply['state'] in ('queued', 'running'):
- r.info("Request ID: %s, sleep: %s", reply['request_id'], sleep)
- time.sleep(sleep)
- elif reply['state'] in ('failed',):
- r.error("Message: %s", reply['error'].get('message'))
- r.error("Reason: %s", reply['error'].get('reason'))
- for n in reply.get('error', {}).get('context', {}).get('traceback', '').split('\n'):
- if n.strip() == '':
- break
- r.error(" %s", n)
- raise Exception("%s. %s." % (reply['error'].get('message'), reply['error'].get('reason')))
-
-r.download("test.nc")
diff --git a/setup.py b/setup.py
index 339549b..337f08f 100644
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ def read(fname):
return io.open(file_path, encoding='utf-8').read()
-version = '0.2.8'
+version = '0.2.9'
setuptools.setup(