summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEddy Comyn-Platt <53045993+EddyCMWF@users.noreply.github.com>2023-02-27 14:04:25 +0000
committerGitHub <noreply@github.com>2023-02-27 14:04:25 +0000
commit83a1a8a64792008e6fe83e5156369b3ebd26fb97 (patch)
treee9b6d59641345d1e8766acffa78328d21be52ebe
parent7361974b7665e6564988d16ede6281a7077a5728 (diff)
Feature/fix GitHub actions (#62)
Use environment variables instead of files containing secrets Remove deprecated python versions and add new python versions 3.10, 3.11
-rw-r--r--.github/workflows/check-and-publish.yml19
1 files changed, 4 insertions, 15 deletions
diff --git a/.github/workflows/check-and-publish.yml b/.github/workflows/check-and-publish.yml
index 10831bf..9b783de 100644
--- a/.github/workflows/check-and-publish.yml
+++ b/.github/workflows/check-and-publish.yml
@@ -17,7 +17,7 @@ jobs:
fail-fast: false
matrix:
platform: [windows-latest, ubuntu-latest, macos-latest]
- python-version: ["2.7", "3.6", "3.7", "3.8", "3.9"]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "3.11"]
name: Python ${{ matrix.python-version }} on ${{ matrix.platform }}
runs-on: ${{ matrix.platform }}
@@ -31,21 +31,10 @@ jobs:
with:
python-version: ${{ matrix.python-version }}
- - name: Tokens
- shell: python
- env:
- CDSAPIRC: ${{ secrets.CDSAPIRC }}
-
- run: |
- from __future__ import print_function
- import os
- for n in ('CDSAPIRC',):
- m = os.path.expanduser("~/." + n.lower())
- if os.environ[n]:
- with open(m, "w") as f:
- print(os.environ[n], file=f)
-
- name: Tests
+ env:
+ CDSAPI_URL: https://cds.climate.copernicus.eu/api/v2
+ CDSAPI_KEY: ${{ secrets.CDSAPI_KEY }}
run: |
python setup.py develop
pip install pytest