summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-06-23 11:59:35 +0200
committerGard Spreemann <gspr@nonempty.org>2020-06-23 11:59:35 +0200
commit868c52f5271e1710a687b4f6bf2584b89b6bf80a (patch)
tree53455159371169520a53a2636289d6f9904c7288
parent07737453e34c2b9f78fcef7ba95f74ae54acf7bc (diff)
parentec2ebb91592da0f20df8d21e26c649d86a300d13 (diff)
Merge tag 'upstream/0.3.0' into debian/sid
Upstream 0.3.0 tarball as released on PyPI.
-rw-r--r--PKG-INFO2
-rw-r--r--cdsapi.egg-info/PKG-INFO2
-rw-r--r--cdsapi.egg-info/SOURCES.txt1
-rw-r--r--cdsapi/api.py3
-rw-r--r--setup.py2
-rwxr-xr-xx.py31
6 files changed, 37 insertions, 4 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 30e252e..03ed29b 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: cdsapi
-Version: 0.2.9
+Version: 0.3.0
Summary: Climate Data Store API
Home-page: https://software.ecmwf.int/stash/projects/CDS/repos/cdsapi
Author: ECMWF
diff --git a/cdsapi.egg-info/PKG-INFO b/cdsapi.egg-info/PKG-INFO
index 30e252e..03ed29b 100644
--- a/cdsapi.egg-info/PKG-INFO
+++ b/cdsapi.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: cdsapi
-Version: 0.2.9
+Version: 0.3.0
Summary: Climate Data Store API
Home-page: https://software.ecmwf.int/stash/projects/CDS/repos/cdsapi
Author: ECMWF
diff --git a/cdsapi.egg-info/SOURCES.txt b/cdsapi.egg-info/SOURCES.txt
index cbd1fce..f8d641d 100644
--- a/cdsapi.egg-info/SOURCES.txt
+++ b/cdsapi.egg-info/SOURCES.txt
@@ -7,6 +7,7 @@ example-glaciers.py
setup.cfg
setup.py
tox.ini
+x.py
cdsapi/__init__.py
cdsapi/api.py
cdsapi.egg-info/PKG-INFO
diff --git a/cdsapi/api.py b/cdsapi/api.py
index 70efa25..2bd5c14 100644
--- a/cdsapi/api.py
+++ b/cdsapi/api.py
@@ -341,7 +341,8 @@ class Client(object):
result = self._api('%s/tasks/services/%s/clientid-%s' % (self.url, name, uuid.uuid4().hex), request, 'PUT')
return result
- def workflow(self, code, *args, workflow_name='application', **kwargs):
+ def workflow(self, code, *args, **kwargs):
+ workflow_name=kwargs.pop('workflow_name', 'application')
params = dict(code=code,
args=args,
kwargs=kwargs,
diff --git a/setup.py b/setup.py
index 337f08f..920bf2d 100644
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ def read(fname):
return io.open(file_path, encoding='utf-8').read()
-version = '0.2.9'
+version = '0.3.0'
setuptools.setup(
diff --git a/x.py b/x.py
new file mode 100755
index 0000000..c6bf50c
--- /dev/null
+++ b/x.py
@@ -0,0 +1,31 @@
+#!/usr/bin/env python
+
+# (C) Copyright 2018 ECMWF.
+#
+# This software is licensed under the terms of the Apache Licence Version 2.0
+# which can be obtained at http://www.apache.org/licenses/LICENSE-2.0.
+# In applying this licence, ECMWF does not waive the privileges and immunities
+# granted to it by virtue of its status as an intergovernmental organisation nor
+# does it submit to any jurisdiction.
+
+import cdsapi
+
+c = cdsapi.Client()
+
+c.retrieve("reanalysis-era5-complete",
+ {
+
+ 'class': 'ea',
+ 'expver': '5',
+ 'stream': 'oper',
+ 'type': 'fc',
+ 'step': '3/to/12/by/3',
+ 'param': '130.128',
+ 'levtype': 'ml',
+ 'levelist': '1/10/50/100',
+ 'date': '2020-06-01',
+ 'time': '06/18',
+ 'area': '80/-50/-25/0', # North, West, South, East. Default: global
+ 'grid': '1.0/1.0', # Latitude/longitude grid: east-west (longitude) and north-south resolution (latitude). Default: reduced Gaussian grid
+ },
+ 'x.grib')