summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-05-23 13:45:21 +0200
committerGard Spreemann <gspr@nonempty.org>2019-05-23 13:45:21 +0200
commita025b6c38c32e4a580c6f521cee277a64d04fc12 (patch)
tree8d0fa5ab8fd50acb085a0113232e82c5279bc047
Initial Debian packaging.
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control25
-rw-r--r--debian/copyright31
-rwxr-xr-xdebian/rules9
5 files changed, 71 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..7d2e869
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+python-cdsapi (0.1.4-1) UNRELEASED; urgency=medium
+
+ * Initial release. (Closes: #XXXXXX)
+
+ -- Gard Spreemann <gspr@nonempty.org> Thu, 23 May 2019 13:33:27 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..48082f7
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+12
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..9a545f2
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,25 @@
+Source: python-cdsapi
+Maintainer: Gard Spreemann <gspr@nonempty.org>
+Section: python
+Priority: optional
+Standards-Version: 4.3.0.3
+Build-Depends: debhelper (>= 12),
+ dh-python,
+ python3-all
+Rules-Requires-Root: no
+Homepage: https://pypi.org/project/cdsapi/
+Vcs-Browser: https://git.nonempty.org/debian-cdsapi
+Vcs-Git: https://git.nonempty.org/debian-cdsapi -b debian/sid
+
+Package: python3-cdsapi
+Section: python
+Architecture: all
+Depends: ${misc:Depends},
+ ${python3:Depends},
+ python3-requests
+Description: Python 3 interface for the ECMWF CDS API
+ This is Python implementation of the European Centre for Medium-Range
+ Weather Forecasts' (ECMWF) Climate Data Store (CDS) API.
+ .
+ More information about the CDS can be found on
+ https://cds.climate.copernicus.eu \ No newline at end of file
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..e06d695
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,31 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: cdsapi
+Source: https://pypi.org/project/cdsapi
+
+Files: *
+Copyright: 2018-2019 European Centre for Medium-Range Weather Forecasts (ECMWF)
+License: Apache-2.0
+
+Files: debian/*
+Copyright: 2019 Gard Spreemann <gspreemann@gmail.com>
+License: Apache-2.0
+
+License: Apache-2.0
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+ .
+ http://www.apache.org/licenses/LICENSE-2.0
+ .
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied. See the License for the specific language governing
+ permissions and limitations under the License.
+ .
+ In applying this licence, ECMWF does not waive the privileges and immunities
+ granted to it by virtue of its status as an intergovernmental organisation nor
+ does it submit to any jurisdiction.
+ .
+ On Debian systems, the full text of the Apache license can be found
+ in the file `/usr/share/common-licenses/Apache-2.0'.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..338a247
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,9 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+
+export PYBUILD_NAME = cdsapi
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+