summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorb8raoult <53792887+b8raoult@users.noreply.github.com>2020-09-15 10:34:51 +0100
committerGitHub <noreply@github.com>2020-09-15 10:34:51 +0100
commitd1b2c46c6983272d55051a2a41ab3bf1bf4d628e (patch)
tree98a442b94ef1a1338d4b3893ace72a7b408c408b
parent7b8ac266be9f0843ece82e1bb5e9b2ac41a0be46 (diff)
Create python-publish.yml
-rw-r--r--.github/workflows/python-publish.yml31
1 files changed, 31 insertions, 0 deletions
diff --git a/.github/workflows/python-publish.yml b/.github/workflows/python-publish.yml
new file mode 100644
index 0000000..2b290d1
--- /dev/null
+++ b/.github/workflows/python-publish.yml
@@ -0,0 +1,31 @@
+# This workflows will upload a Python Package using Twine when a release is created
+# For more information see: https://help.github.com/en/actions/language-and-framework-guides/using-python-with-github-actions#publishing-to-package-registries
+
+name: Upload Python Package
+
+on:
+ release:
+ types: [created]
+
+jobs:
+ deploy:
+
+ runs-on: ubuntu-latest
+
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python
+ uses: actions/setup-python@v2
+ with:
+ python-version: '3.x'
+ - name: Install dependencies
+ run: |
+ python -m pip install --upgrade pip
+ pip install setuptools wheel twine
+ - name: Build and publish
+ env:
+ TWINE_USERNAME: ${{ secrets.PYPI_USERNAME }}
+ TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
+ run: |
+ python setup.py sdist
+ twine upload dist/*