summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaudouin Raoult <baudouin.raoult@ecmwf.int>2018-05-11 04:54:43 +0100
committerBaudouin Raoult <baudouin.raoult@ecmwf.int>2018-05-11 04:54:43 +0100
commit0587bf7d3abeb53d1e4032db51fe1ca557e91b37 (patch)
tree4c0d057c21e8e96dbe7c7b9152332dda67d53075
parent7c7c6b60be37506e27fe3978f75c90732f9bc638 (diff)
parent117c9bfab28c84a2a7bf48443fe074b68902d222 (diff)
Merge branch 'master' of https://software.ecmwf.int/stash/scm/cds/cdsapi
-rw-r--r--MANIFEST.in3
-rw-r--r--README.rst25
-rw-r--r--setup.py2
3 files changed, 28 insertions, 2 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..07b2794
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,3 @@
+include *.in
+include *.rst
+recursive-include cdsapi *.py
diff --git a/README.rst b/README.rst
index 0db68d7..0be3bba 100644
--- a/README.rst
+++ b/README.rst
@@ -1 +1,24 @@
-Todo
+
+Install
+-------
+
+Install via `pip` with::
+
+ $ pip install cdsapi
+
+
+Configure
+---------
+
+Get your API key from the CDS portal and write it into the configuration file::
+
+ $ vim ~/.cdsapi
+
+Test
+----
+
+ $ python
+ >>> import cdsapi
+ >>> cds = cdsapi.Client()
+ >>> cds.get_resource("insitu-glaciers-extent", {})
+ ...
diff --git a/setup.py b/setup.py
index d6cf052..578ee59 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ setuptools.setup(
author='ECMWF',
author_email='software@ecmwf.int',
license='Apache 2.0',
- url='https://software.ecmwf.int/stash/projects/CST/repos/cdscompute',
+ url='https://software.ecmwf.int/stash/projects/CST/repos/cdsapi',
description="Climate Data Store API",
long_description=read('README.rst'),
packages=setuptools.find_packages(),