summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBaudouin Raoult <baudouin.raoult@ecmwf.int>2018-05-09 10:50:50 +0100
committerBaudouin Raoult <baudouin.raoult@ecmwf.int>2018-05-09 10:50:50 +0100
commit43d0ab57e04e06c9377b26c6eb3dcc8ea385943a (patch)
tree920426f200b5bb7864878cbe82d21d1d3d4acdcb /setup.py
parent9fc82c6dd329e43e3487fdcaf058ee3ef782b17d (diff)
cdsapi
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py50
1 files changed, 50 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d6cf052
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,50 @@
+#!/usr/bin/env python3
+#
+
+import io
+import os.path
+
+import setuptools
+
+
+def read(fname):
+ file_path = os.path.join(os.path.dirname(__file__), fname)
+ return io.open(file_path, encoding='utf-8').read()
+
+
+version = '0.0.1'
+
+
+setuptools.setup(
+ name='cdsapi',
+ version=version,
+ author='ECMWF',
+ author_email='software@ecmwf.int',
+ license='Apache 2.0',
+ url='https://software.ecmwf.int/stash/projects/CST/repos/cdscompute',
+ description="Climate Data Store API",
+ long_description=read('README.rst'),
+ packages=setuptools.find_packages(),
+ include_package_data=True,
+ setup_requires=[
+ 'pytest-runner',
+ ],
+ install_requires=[
+ 'requests',
+ ],
+ tests_require=[
+ 'pytest',
+ ],
+ zip_safe=True,
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Operating System :: OS Independent',
+ ],
+)