summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py65
1 files changed, 65 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..041cdcc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,65 @@
+#!/usr/bin/env python3
+
+# Copyright 2018 European Centre for Medium-Range Weather Forecasts (ECMWF)
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# In applying this licence, ECMWF does not waive the privileges and immunities
+# granted to it by virtue of its status as an intergovernmental organisation nor
+# does it submit to any jurisdiction.
+
+
+import io
+import os.path
+
+import setuptools
+
+
+def read(fname):
+ file_path = os.path.join(os.path.dirname(__file__), fname)
+ return io.open(file_path, encoding='utf-8').read()
+
+
+version = '0.1.4'
+
+
+setuptools.setup(
+ name='cdsapi',
+ version=version,
+ author='ECMWF',
+ author_email='software.support@ecmwf.int',
+ license='Apache 2.0',
+ url='https://software.ecmwf.int/stash/projects/CDS/repos/cdsapi',
+ description="Climate Data Store API",
+ long_description=read('README.rst'),
+ packages=setuptools.find_packages(),
+ include_package_data=True,
+ install_requires=[
+ 'requests>=2.5.0',
+ ],
+ zip_safe=True,
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Operating System :: OS Independent',
+ ],
+)