summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini10
1 files changed, 9 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 1d50849..d97570f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = qc, py36, py35, py34, py27, pypy3, pypy, deps
+envlist = qc, py311, py310, py39, py38, py37, pypy3, pypy, deps
[testenv]
setenv = PYTHONPATH = {toxinidir}
@@ -14,3 +14,11 @@ commands = pytest -v --pep8 --mccabe --cov=cdsapi --cov-report=html --cache-clea
[testenv:deps]
deps =
commands = python setup.py test
+
+
+[black]
+line_length=120
+[isort]
+profile=black
+[flake8]
+max-line-length = 120 \ No newline at end of file