summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2017-07-07 11:18:49 +0200
committerRémi Flamary <remi.flamary@gmail.com>2017-07-07 11:18:49 +0200
commit3867a1441f34bac5ac4270b903f9582a23fa2671 (patch)
tree3b500a8024a6fccf332c8e96eb09bdbce9acf0c9 /.travis.yml
parente6887665538f437e9aa0b0cf44d54be2dff8cd74 (diff)
better
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml26
1 files changed, 12 insertions, 14 deletions
diff --git a/.travis.yml b/.travis.yml
index ea809d9..f10131a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,12 +1,16 @@
language: python
-os:
- - linux
-python:
- - "2.7"
- - "3.4"
- # does not have headers provided, please ask https://launchpad.net/~pypy/+archive/ppa
- # maintainers to fix their pypy-dev package.
- # - "pypy"
+matrix:
+ allow_failures:
+ - os: osx
+ include:
+ - os: osx
+ language: python
+ - os: linux
+ sudo: required
+ python: 3.4
+ - os: linux
+ sudo: required
+ python: 2.7
before_install:
- ./.travis/before_install.sh
# command to install dependencies
@@ -14,10 +18,4 @@ install:
- pip install -r requirements.txt
- python setup.py install
# command to run tests
-matrix:
- include:
- - os: osx
- language: python
- - os: linux
- sudo: required
script: python test/test_load_module.py -v