summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2019-09-09 14:55:04 +0200
committerRémi Flamary <remi.flamary@gmail.com>2019-09-09 14:55:04 +0200
commitb2a7afb848a78570d01f35f9b239be8838520edc (patch)
treefc243208d24f5488d5ce06298b2ebb39b76be9bb /.travis.yml
parentc698e0aa20d28e36d25f87082855a490283f3c88 (diff)
parentf251b4d080a577c2cee890ca43d8ec3658332021 (diff)
merge new unbalanced
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml5
1 files changed, 5 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index 0dfb0d0..5b3a26e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -25,6 +25,9 @@ matrix:
# language: shell # 'language: python' is an error on Travis CI Windows
# before_install: choco install python
# env: PATH=/c/Python37:/c/Python37/Scripts:$PATH
+# before_script: # configure a headless display to test plot generation
+# - "export DISPLAY=:99.0"
+# - sleep 3 # give xvfb some time to start
before_install:
- ./.travis/before_install.sh
# command to install dependencies
@@ -34,6 +37,8 @@ install:
- pip install flake8 pytest "pytest-cov<2.6"
- pip install .
# command to run tests + check syntax style
+services:
+ - xvfb
script:
- python setup.py develop
- flake8 examples/ ot/ test/