summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2018-09-24 15:47:29 +0200
committerRémi Flamary <remi.flamary@gmail.com>2018-09-24 15:47:29 +0200
commit5bb13e439578ad8952bece8f491ce68bb1efe47d (patch)
tree1a6b9bd55f9aa90cb4aaddeac86796d482cb981f /.travis.yml
parentc8c397b6e1747d6593ba139d0a4f825fe39f5cc6 (diff)
do code coverage in travis
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml4
1 files changed, 2 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index d146395..90a0ff4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -26,11 +26,11 @@ before_script: # configure a headless display to test plot generation
# command to install dependencies
install:
- pip install -r requirements.txt
- - pip install flake8 pytest
+ - pip install flake8 pytest pytest-cov
- pip install .
# command to run tests + check syntax style
script:
- python setup.py develop
- flake8 examples/ ot/ test/
- - python -m pytest -v test/
+ - python -m pytest -v test/ --cov=ot
# - py.test ot test