summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorAlexandre Gramfort <alexandre.gramfort@m4x.org>2020-04-21 17:40:32 +0200
committerAlexandre Gramfort <alexandre.gramfort@m4x.org>2020-04-21 17:40:32 +0200
commitf9638166521a1160838fae75e2a2e318d645460e (patch)
tree8b3f08cf68ce7c72ed1552fda1facf444fcda6da /.travis.yml
parent0b2d808aaebb1cab60a272ea7901d5f77df43a9f (diff)
rm travis
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml50
1 files changed, 0 insertions, 50 deletions
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 3f63867..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,50 +0,0 @@
-dist: xenial # required for Python >= 3.7
-language: python
-matrix:
- # allow_failures:
- # - os: osx
- # - os: windows
- include:
- - os: linux
- sudo: required
- python: 3.5
- - os: linux
- sudo: required
- python: 3.6
- - os: linux
- sudo: required
- python: 3.7
- - os: linux
- sudo: required
- python: 3.8
- # - os: osx
- # sudo: required
- # language: generic
- # - name: "Python 3.7.3 on Windows"
- # os: windows # Windows 10.0.17134 N/A Build 17134
- # language: shell # 'language: python' is an error on Travis CI Windows
- # before_install: choco install python
- # env: PATH=/c/Python37:/c/Python37/Scripts:$PATH
-# before_script: # configure a headless display to test plot generation
-# - "export DISPLAY=:99.0"
-# - sleep 3 # give xvfb some time to start
-before_install:
- - ./.travis/before_install.sh
-# command to install dependencies
-install:
- - pip install -r requirements.txt
- - pip install -U "numpy>=1.14" scipy # for numpy array formatting in doctests
- - pip install flake8 pytest "pytest-cov<2.6" codecov
- - pip install -U "sklearn"
- - pip install .
-# command to run tests + check syntax style
-services:
- - xvfb
-script:
- - python setup.py develop
- - flake8 examples/ ot/ test/
- - python -m pytest -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot
- # - py.test ot test
-after_script:
- # Need to run from source dir to execute "git" commands
- - codecov;