summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2019-07-02 16:42:26 +0200
committerGitHub <noreply@github.com>2019-07-02 16:42:26 +0200
commit8b3927bb5e8935c3dbddf054f054dc0c036fbdfe (patch)
treed2eecc0bb96d5937d30e43993a732ae32eec3438 /.travis.yml
parenta9b8af146648ee2ae50baf46e69e6281f6b279e4 (diff)
parent5b6eb56f2d4bfdaeaa45970c386c42c21d7d1caf (diff)
Merge pull request #90 from rtavenar/dev-doctests
[MRG] Have Travis actually execute doctests
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml3
1 files changed, 2 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 50ff22c..5e5694b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -26,11 +26,12 @@ before_script: # configure a headless display to test plot generation
# command to install dependencies
install:
- pip install -r requirements.txt
+ - pip install -U "numpy>=1.14" "scipy<1.3" # for numpy array formatting in doctests + scipy version: otherwise, pymanopt fails, cf <https://github.com/pymanopt/pymanopt/issues/77>
- pip install flake8 pytest "pytest-cov<2.6"
- pip install .
# command to run tests + check syntax style
script:
- python setup.py develop
- flake8 examples/ ot/ test/
- - python -m pytest -v test/ --cov=ot
+ - python -m pytest -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot
# - py.test ot test