summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2019-08-21 14:43:58 +0200
committerGitHub <noreply@github.com>2019-08-21 14:43:58 +0200
commitabfe183a49caaf74a07e595ac40920dae05a3c22 (patch)
tree4d5fe2d98d249a252cda18db29ff47edc472a2ab /.travis.yml
parentb2157e9b3458388571f6ae87d80f47f500dfa166 (diff)
parentce86d1476b32771d32b7e55566e7cab45bb57b3a (diff)
Merge pull request #100 from ngayraud/add_unbalanced_da
[MRG] Adds Unbalaced transport to domain adaptation methods + bugfixes
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml5
1 files changed, 3 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 5e5694b..72fd29a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -13,7 +13,7 @@ matrix:
python: 3.5
- os: linux
sudo: required
- python: 3.6
+ python: 3.6
- os: linux
sudo: required
python: 2.7
@@ -21,7 +21,6 @@ before_install:
- ./.travis/before_install.sh
before_script: # configure a headless display to test plot generation
- "export DISPLAY=:99.0"
- - "sh -e /etc/init.d/xvfb start"
- sleep 3 # give xvfb some time to start
# command to install dependencies
install:
@@ -30,6 +29,8 @@ install:
- pip install flake8 pytest "pytest-cov<2.6"
- pip install .
# command to run tests + check syntax style
+services:
+ - xvfb
script:
- python setup.py develop
- flake8 examples/ ot/ test/