summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Tavenard <romain.tavenard@univ-rennes2.fr>2019-07-01 11:02:11 +0200
committerRomain Tavenard <romain.tavenard@univ-rennes2.fr>2019-07-01 11:02:11 +0200
commit93a74fe4d477e1735e9ce21ee4113281f58b4dcf (patch)
tree6ac4c1b8aec72efdfcc47eab9bac4cb1b35ac081
parenta9b8af146648ee2ae50baf46e69e6281f6b279e4 (diff)
Explicit doctest call in travis + removed uneffective doctest in test_ot
-rw-r--r--.travis.yml2
-rw-r--r--test/test_ot.py10
2 files changed, 1 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index 50ff22c..d6b4232 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -32,5 +32,5 @@ install:
script:
- python setup.py develop
- flake8 examples/ ot/ test/
- - python -m pytest -v test/ --cov=ot
+ - python -m pytest -v test/ ot/ --doctest-modules --cov=ot
# - py.test ot test
diff --git a/test/test_ot.py b/test/test_ot.py
index 3c4ac11..ac86602 100644
--- a/test/test_ot.py
+++ b/test/test_ot.py
@@ -14,16 +14,6 @@ from ot.datasets import make_1D_gauss as gauss
import pytest
-def test_doctest():
- import doctest
-
- # test lp solver
- doctest.testmod(ot.lp, verbose=True)
-
- # test bregman solver
- doctest.testmod(ot.bregman, verbose=True)
-
-
def test_emd_emd2():
# test emd and emd2 for simple identity
n = 100