summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2019-06-25 08:43:00 +0200
committerRémi Flamary <remi.flamary@gmail.com>2019-06-25 08:43:00 +0200
commit042b52d4edad20d246481c389007ba1abb67c3b4 (patch)
tree4395c4e3ac390996302bbfd9f6ed0b515629cd14
parentc112190ab0cf9b02a25fb86919a11f9544cd5c58 (diff)
pep8
-rw-r--r--README.md15
-rw-r--r--ot/gromov.py10
2 files changed, 19 insertions, 6 deletions
diff --git a/README.md b/README.md
index b6b215c..288ba13 100644
--- a/README.md
+++ b/README.md
@@ -53,6 +53,12 @@ The library has been tested on Linux, MacOSX and Windows. It requires a C++ comp
#### Pip installation
+Note that due to a limitation of pip, `cython` and `numpy` need to be installed
+prior to installing POT. This can be done easily with
+```
+pip install numpy cython
+```
+
You can install the toolbox through PyPI with:
```
pip install POT
@@ -62,6 +68,8 @@ or get the very latest version by downloading it and then running:
python setup.py install --user # for user install (no root)
```
+
+
#### Anaconda installation with conda-forge
If you use the Anaconda python distribution, POT is available in [conda-forge](https://conda-forge.org). To install it and the required dependencies:
@@ -150,7 +158,12 @@ You can also see the notebooks with [Jupyter nbviewer](https://nbviewer.jupyter.
## Acknowledgements
-The contributors to this library are:
+This toolbox has been created and is maintained by
+
+* [Rémi Flamary](http://remi.flamary.com/)
+* [Nicolas Courty](http://people.irisa.fr/Nicolas.Courty/)
+
+The contributors to this library are
* [Rémi Flamary](http://remi.flamary.com/)
* [Nicolas Courty](http://people.irisa.fr/Nicolas.Courty/)
diff --git a/ot/gromov.py b/ot/gromov.py
index 43729dc..cd961b0 100644
--- a/ot/gromov.py
+++ b/ot/gromov.py
@@ -359,7 +359,7 @@ def fused_gromov_wasserstein(M, C1, C2, p, q, loss_fun='square_loss', alpha=0.5,
.. math::
\gamma = arg\min_\gamma (1-\alpha)*<\gamma,M>_F + \alpha* \sum_{i,j,k,l}
L(C1_{i,k},C2_{j,l})*T_{i,j}*T_{k,l}
-
+
s.t. \gamma 1 = p
\gamma^T 1= q
\gamma\geq 0
@@ -414,7 +414,7 @@ def fused_gromov_wasserstein(M, C1, C2, p, q, loss_fun='square_loss', alpha=0.5,
and Courty Nicolas "Optimal Transport for structured data with
application on graphs", International Conference on Machine Learning
(ICML). 2019.
-
+
"""
constC, hC1, hC2 = init_matrix(C1, C2, p, q, loss_fun)
@@ -442,7 +442,7 @@ def fused_gromov_wasserstein2(M, C1, C2, p, q, loss_fun='square_loss', alpha=0.5
.. math::
\min_\gamma (1-\alpha)*<\gamma,M>_F + \alpha* \sum_{i,j,k,l}
L(C1_{i,k},C2_{j,l})*T_{i,j}*T_{k,l}
-
+
s.t. \gamma 1 = p
\gamma^T 1= q
@@ -647,7 +647,7 @@ def entropic_gromov_wasserstein(C1, C2, p, q, loss_fun, epsilon,
Returns
-------
T : ndarray, shape (ns, nt)
- Optimal coupling between the two spaces
+ Optimal coupling between the two spaces
References
----------
@@ -1024,7 +1024,7 @@ def fgw_barycenters(N, Ys, Cs, ps, lambdas, alpha, fixed_structure=False, fixed_
T : list of (N,ns) transport matrices
Ms : all distance matrices between the feature of the barycenter and the
other features dist(X,Ys) shape (N,ns)
-
+
References
----------
.. [24] Vayer Titouan, Chapel Laetitia, Flamary R{\'e}mi, Tavenard Romain