summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2020-04-24 10:56:49 +0200
committerGitHub <noreply@github.com>2020-04-24 10:56:49 +0200
commitb53fb23b538e0b7f6498bc217f02adac3c8f7d07 (patch)
tree0ba34df939d25280675facd9434463951d4245a4
parent1d3d2d055fcf284279a155061d5250198a2c1848 (diff)
parentfa88aa90dc001ad7cc39e667d9e54eb9053163df (diff)
Merge pull request #150 from agramfort/rm_travis
[WIP] rm travis
-rw-r--r--.github/workflows/pythonpackage.yml3
-rw-r--r--.travis.yml50
-rwxr-xr-x.travis/before_install.sh15
-rw-r--r--README.md1
4 files changed, 2 insertions, 67 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index 9c35afa..0792059 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -36,7 +36,7 @@ jobs:
# stop the build if there are Python syntax errors or undefined names
flake8 . --count --select=E9,F63,F7,F82 --show-source --statistics
# exit-zero treats all errors as warnings. The GitHub editor is 127 chars wide
- flake8 examples/ ot/ test/ --count --max-line-length=127 --statistics
+ flake8 examples/ ot/ test/ --count --max-line-length=127 --statistics
- name: Install POT
run: |
pip install -e .
@@ -47,6 +47,7 @@ jobs:
run: |
codecov
+
macos:
runs-on: macOS-latest
strategy:
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 3f63867..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,50 +0,0 @@
-dist: xenial # required for Python >= 3.7
-language: python
-matrix:
- # allow_failures:
- # - os: osx
- # - os: windows
- include:
- - os: linux
- sudo: required
- python: 3.5
- - os: linux
- sudo: required
- python: 3.6
- - os: linux
- sudo: required
- python: 3.7
- - os: linux
- sudo: required
- python: 3.8
- # - os: osx
- # sudo: required
- # language: generic
- # - name: "Python 3.7.3 on Windows"
- # os: windows # Windows 10.0.17134 N/A Build 17134
- # language: shell # 'language: python' is an error on Travis CI Windows
- # before_install: choco install python
- # env: PATH=/c/Python37:/c/Python37/Scripts:$PATH
-# before_script: # configure a headless display to test plot generation
-# - "export DISPLAY=:99.0"
-# - sleep 3 # give xvfb some time to start
-before_install:
- - ./.travis/before_install.sh
-# command to install dependencies
-install:
- - pip install -r requirements.txt
- - pip install -U "numpy>=1.14" scipy # for numpy array formatting in doctests
- - pip install flake8 pytest "pytest-cov<2.6" codecov
- - pip install -U "sklearn"
- - pip install .
-# command to run tests + check syntax style
-services:
- - xvfb
-script:
- - python setup.py develop
- - flake8 examples/ ot/ test/
- - python -m pytest -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot
- # - py.test ot test
-after_script:
- # Need to run from source dir to execute "git" commands
- - codecov;
diff --git a/.travis/before_install.sh b/.travis/before_install.sh
deleted file mode 100755
index 0ae6249..0000000
--- a/.travis/before_install.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/bash
-
-if [[ $TRAVIS_OS_NAME == 'osx' ]]; then
-
- # Install some custom requirements on OS X
- # e.g. brew install pyenv-virtualenv
- #brew update
- #brew install python
- sudo easy_install -U pip
-
-else
- # Install some custom requirements on Linux
- sudo apt-get update -q
- sudo apt-get install libblas-dev liblapack-dev libatlas-base-dev
-fi
diff --git a/README.md b/README.md
index 214f932..1b5c58d 100644
--- a/README.md
+++ b/README.md
@@ -2,7 +2,6 @@
[![PyPI version](https://badge.fury.io/py/POT.svg)](https://badge.fury.io/py/POT)
[![Anaconda Cloud](https://anaconda.org/conda-forge/pot/badges/version.svg)](https://anaconda.org/conda-forge/pot)
-[![Build Status](https://travis-ci.org/PythonOT/POT.svg?branch=master)](https://travis-ci.org/PythonOT/POT)
[![Build Status](https://github.com/PythonOT/POT/workflows/build/badge.svg)](https://github.com/PythonOT/POT/actions)
[![Codecov Status](https://codecov.io/gh/PythonOT/POT/branch/master/graph/badge.svg)](https://codecov.io/gh/PythonOT/POT)
[![Downloads](https://pepy.tech/badge/pot)](https://pepy.tech/project/pot)