summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2020-04-23 10:31:11 +0200
committerGitHub <noreply@github.com>2020-04-23 10:31:11 +0200
commitbacb0b992aa4e1ba7e5fd0beb0bf9617c801f833 (patch)
tree062b8f3c6ac018580d76eb2583da2fab7290b943
parente7e485ae4ef5cfc8ecc33dadf15174ff05987b80 (diff)
parentebf8fe9d1c3ff7885c00f695812964faf119486c (diff)
Merge pull request #157 from PythonOT/build_wheels
[MRG] build wheels on release
-rw-r--r--.github/workflows/build_wheels.yml46
-rw-r--r--README.md11
2 files changed, 52 insertions, 5 deletions
diff --git a/.github/workflows/build_wheels.yml b/.github/workflows/build_wheels.yml
new file mode 100644
index 0000000..7c13c33
--- /dev/null
+++ b/.github/workflows/build_wheels.yml
@@ -0,0 +1,46 @@
+name: Build dist and wheels
+
+on:
+ release:
+
+jobs:
+ build_wheels:
+ name: ${{ matrix.os }}
+ runs-on: ${{ matrix.os }}
+ strategy:
+ matrix:
+ os: [ubuntu-18.04]
+ # macosx-latest, windows-latest
+
+ steps:
+ - uses: actions/checkout@v1
+ - name: Set up Python 3.8
+ uses: actions/setup-python@v1
+ with:
+ python-version: 3.8
+
+ - name: Install dependencies
+ run: |
+ python -m pip install --upgrade pip
+ pip install -r requirements.txt
+ pip install -U "cython"
+
+ - name: Install cibuildwheel
+ run: |
+ python -m pip install cibuildwheel==1.3.0
+
+ - name: Install Visual C++ for Python 2.7
+ if: startsWith(matrix.os, 'windows')
+ run: |
+ choco install vcpython27 -f -y
+
+ - name: Build wheel
+ env:
+ CIBW_BEFORE_BUILD: "pip install numpy cython"
+ run: |
+ python -m cibuildwheel --output-dir wheelhouse
+
+ - uses: actions/upload-artifact@v1
+ with:
+ name: wheels
+ path: ./wheelhouse
diff --git a/README.md b/README.md
index ad0d810..214f932 100644
--- a/README.md
+++ b/README.md
@@ -50,9 +50,10 @@ Some demonstrations are available in the [documentation](https://pythonot.gith
#### Using and citing the toolbox
If you use this toolbox in your research and find it useful, please cite POT
-using the following bibtex reference:
+using the following reference:
```
-Rémi Flamary and Nicolas Courty, POT Python Optimal Transport library, Website: https://pythonot.github.io/, 2017
+Rémi Flamary and Nicolas Courty, POT Python Optimal Transport library,
+Website: https://pythonot.github.io/, 2017
```
In Bibtex format:
@@ -86,9 +87,9 @@ You can install the toolbox through PyPI with:
```
pip install POT
```
-or get the very latest version by downloading it and then running:
+or get the very latest version by running:
```
-python setup.py install --user # for user install (no root)
+pip install -U https://github.com/PythonOT/POT/archive/master.zip # with --user for user install (no root)
```
@@ -165,7 +166,7 @@ This toolbox has been created and is maintained by
The contributors to this library are
-* [Alexandre Gramfort](http://alexandre.gramfort.net/) (CI)
+* [Alexandre Gramfort](http://alexandre.gramfort.net/) (CI, documentation)
* [Laetitia Chapel](http://people.irisa.fr/Laetitia.Chapel/) (Partial OT)
* [Michael Perrot](http://perso.univ-st-etienne.fr/pem82055/) (Mapping estimation)
* [Léo Gautheron](https://github.com/aje) (GPU implementation)