summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2019-07-05 09:43:37 +0200
committerRémi Flamary <remi.flamary@gmail.com>2019-07-05 09:43:37 +0200
commit852e330bfca616e033fa4453fcd77bd4f1af1a06 (patch)
treebfd4f1b933224f39f255904744c76808e0ede36f
parent952503e02b1fc9bdf0811b937baacca57e4a98f1 (diff)
prepare for version 1.0
-rw-r--r--Makefile5
-rw-r--r--ot/__init__.py15
2 files changed, 13 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 4cdb7d1..bd3c1b4 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,8 @@
PYTHON=python3
branch := $(shell git symbolic-ref --short -q HEAD)
+CIBW_BEFORE_BUILD="pip install numpy cython"
+
help :
@echo "The following make targets are available:"
@@ -73,5 +75,8 @@ autopep8 :
aautopep8 :
autopep8 -air test ot examples --jobs -1
+
+wheels:
+ cibuildwheel --platform linux --output-dir dist
FORCE :
diff --git a/ot/__init__.py b/ot/__init__.py
index 35ae6fc..571f235 100644
--- a/ot/__init__.py
+++ b/ot/__init__.py
@@ -71,10 +71,11 @@ from .da import sinkhorn_lpl1_mm
# utils functions
from .utils import dist, unif, tic, toc, toq
-__version__ = "0.5.1"
-
-__all__ = ["emd", "emd2", 'emd_1d', "sinkhorn", "sinkhorn2", "utils", 'datasets',
- 'bregman', 'lp', 'tic', 'toc', 'toq', 'gromov',
- 'emd_1d', 'emd2_1d', 'wasserstein_1d',
- 'dist', 'unif', 'barycenter', 'sinkhorn_lpl1_mm', 'da', 'optim',
- 'sinkhorn_unbalanced', "barycenter_unbalanced"]
+__version__ = "1.0.0"
+
+__all__ = ["emd", "emd2", 'emd_1d','emd2_1d', 'wasserstein_1d',
+ "sinkhorn", "sinkhorn2", 'barycenter',
+ 'sinkhorn_lpl1_mm',
+ 'sinkhorn_unbalanced', "barycenter_unbalanced",
+ 'dist', 'unif', 'tic', 'toc', 'toq',
+ "utils", 'datasets', 'bregman', 'lp', 'gromov', 'da', 'optim']