summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2016-10-31 15:37:28 +0100
committerRémi Flamary <remi.flamary@gmail.com>2016-10-31 15:37:28 +0100
commitcc3da98e58d53e57b0f6c0240b8912970fe365c9 (patch)
tree6029fbdcb731117555b5676e2ba6b1cc78345b3a
parentb4af2d3b97294ceaabfadc6209d300e20a196b88 (diff)
v0.1.7
-rw-r--r--ot/da.py2
-rwxr-xr-xsetup.py5
2 files changed, 1 insertions, 6 deletions
diff --git a/ot/da.py b/ot/da.py
index c9b8c7c..3447437 100644
--- a/ot/da.py
+++ b/ot/da.py
@@ -122,7 +122,7 @@ def sinkhorn_lpl1_mm(a,labels_a, b, M, reg, eta=0.1,numItermax = 10,numInnerIter
-class OTDA():
+class OTDA(object):
"""Class for domain adaptation with optimal transport"""
def __init__(self,metric='sqeuclidean'):
diff --git a/setup.py b/setup.py
index 9804422..d9111e0 100755
--- a/setup.py
+++ b/setup.py
@@ -11,11 +11,6 @@ import os
here = path.abspath(path.dirname(__file__))
-
-
-
-#import glob
-
# dirty but working
__version__ = re.search(
r'__version__\s*=\s*[\'"]([^\'"]*)[\'"]', # It excludes inline comment too