summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2020-05-04 17:47:59 +0200
committerGitHub <noreply@github.com>2020-05-04 17:47:59 +0200
commit0a1e8cd6d63b354fe7dfe0439c08417ecf988121 (patch)
tree15107d9158d18a7f2f915cb860f90705928861f1
parente65c1f745cf2eacc6672727e7a3869efd8318768 (diff)
parentba752bdba9a6733ebbb835cdbc59f1195a849245 (diff)
Merge pull request #162 from PythonOT/prepare_v0.7
[WIP] Preparing release 0.7.0
-rw-r--r--.github/workflows/build_wheels.yml2
-rw-r--r--RELEASES.md37
-rw-r--r--ot/__init__.py2
3 files changed, 39 insertions, 2 deletions
diff --git a/.github/workflows/build_wheels.yml b/.github/workflows/build_wheels.yml
index be1719b..662a604 100644
--- a/.github/workflows/build_wheels.yml
+++ b/.github/workflows/build_wheels.yml
@@ -39,7 +39,7 @@ jobs:
- name: Build wheel
env:
- CIBW_SKIP: "pp*-win* pp*-macosx*" # remove pypy on mac and win (wrong version)
+ CIBW_SKIP: "pp*-win* pp*-macosx* cp2* pp*" # remove pypy on mac and win (wrong version)
CIBW_BEFORE_BUILD: "pip install numpy cython"
run: |
python -m cibuildwheel --output-dir wheelhouse
diff --git a/RELEASES.md b/RELEASES.md
index 5fcf485..dbcb4cb 100644
--- a/RELEASES.md
+++ b/RELEASES.md
@@ -1,7 +1,44 @@
# Releases
+## 0.7
+*May 2020*
+This is the new stable release for POT. We have a lot of changes in the documentation and several new features such as Partial OT, Unbalanced and Multi Sources OT Domain Adaptation and several bug fixes. One important change is that we have created a the GitHub organization [PythonOT](https://github.com/PythonOT) that now owns the main POT repository [https://github.com/PythonOT/POT](https://github.com/PythonOT/POT) and the repository for the new documentation hosted at [https://PythonOT.github.io/](https://PythonOT.github.io/).
+This is the first release where the Python 2.7 tests have been removed. Most of the toolbox should still work but we do not offer support for Python 2.7 and will close related Issues.
+
+A lot of changes have been done to the documentation that is now hosted on [https://PythonOT.github.io/](https://PythonOT.github.io/) instead of readthedocs. It was a hard choice but readthedocs did not allow us to run sphinx-gallery to update our beautiful examples and it was a huge amount of work to maintain it. The documentation is now automatically compiled and updated on merge. We also removed the notebooks from the repository for space reason and also because they are all available in the [example gallery](https://pythonot.github.io/auto_examples/index.html). Note that now the output of the documentation build for each commit in the PR is available to check that the doc builds correctly before merging which was not possible with readthedoc.
+
+The CI framework has also been changed with a move from Travis to Github Action which allows us to get faster tests on Windows, MacOS and Linux. We also now report our coverage on [Codecov.io](https://codecov.io/gh/PythonOT/POT) and we have a reasonable 92% coverage. We also now generate wheels for a number of OS and python versions at each merge in the master branch. They are available as artifacts of this [action](https://github.com/PythonOT/POT/actions?query=workflow%3A%22Build+dist+and+wheels%22). This will allow simpler multi-platform releases from now on.
+
+In terms of new features we now have [OTDA Classes for unbalanced OT](https://pythonot.github.io/gen_modules/ot.da.html#ot.da.UnbalancedSinkhornTransport), a new Domain adaptation class form [multi domain problems (JCPOT)](https://pythonot.github.io/auto_examples/domain-adaptation/plot_otda_jcpot.html#sphx-glr-auto-examples-domain-adaptation-plot-otda-jcpot-py), and several solvers to solve the [Partial Optimal Transport](https://pythonot.github.io/auto_examples/unbalanced-partial/plot_partial_wass_and_gromov.html#sphx-glr-auto-examples-unbalanced-partial-plot-partial-wass-and-gromov-py) problems.
+
+This release is also the moment to thank all the POT contributors (old and new) for helping making POT such a nice to use toolbox. A lot of changes (also in the API) are comming for the next versions.
+
+
+#### Features
+
+- New documentation on [https://PythonOT.github.io/](https://PythonOT.github.io/) (PR #160, PR #143, PR #144)
+- Documentation build on CircleCI with sphinx-gallery (PR #145,PR #146, #155)
+- Run sphinx gallery in CI (PR #146)
+- Remove notebooks from repo because available in doc (PR #156)
+- Build wheels in CI (#157)
+- Move from travis to GitHub Action for Windows, MacOS and Linux (PR #148, PR #150)
+- Partial Optimal Transport (PR#141 and PR #142)
+- Laplace regularized OTDA (PR #140)
+- Multi source DA with target shift (PR #137)
+- Screenkhorn algorithm (PR #121)
+
+#### Closed issues
+
+- Bug in Unbalanced OT example (Issue #127)
+- Clean Cython output when calling setup.py clean (Issue #122)
+- Various Macosx compilation problems (Issue #113, Issue #118, PR#130)
+- EMD dimension mismatch (Issue #114, Fixed in PR #116)
+- 2D barycenter bug for non square images (Issue #124, fixed in PR #132)
+- Bad value in EMD 1D (Issue #138, fixed in PR #139)
+- Log bugs for Gromov-Wassertein solver (Issue #107, fixed in PR #108)
+- Weight issues in barycenter function (PR #106)
## 0.6
*July 2019*
diff --git a/ot/__init__.py b/ot/__init__.py
index 2d23610..0e6e2e2 100644
--- a/ot/__init__.py
+++ b/ot/__init__.py
@@ -43,7 +43,7 @@ from .da import sinkhorn_lpl1_mm
# utils functions
from .utils import dist, unif, tic, toc, toq
-__version__ = "0.7.0b"
+__version__ = "0.7.0"
__all__ = ['emd', 'emd2', 'emd_1d', 'sinkhorn', 'sinkhorn2', 'utils', 'datasets',
'bregman', 'lp', 'tic', 'toc', 'toq', 'gromov',