summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2020-05-05 08:18:26 +0200
committerRémi Flamary <remi.flamary@gmail.com>2020-05-05 08:18:26 +0200
commitdbd8f1485c03e4a680b73be59ab1590a59acbe16 (patch)
treefffd47fd6d907566593e9921b07f103074b48a8c
parent8406caafaef8b3683d6a1d44917c404ba780f82c (diff)
add release 0.7.0 in doc
-rw-r--r--RELEASES.md4
-rw-r--r--docs/source/readme.rst2
-rw-r--r--docs/source/releases.rst85
3 files changed, 86 insertions, 5 deletions
diff --git a/RELEASES.md b/RELEASES.md
index dbcb4cb..699f9a6 100644
--- a/RELEASES.md
+++ b/RELEASES.md
@@ -1,6 +1,6 @@
# Releases
-## 0.7
+## 0.7.0
*May 2020*
This is the new stable release for POT. We have a lot of changes in the documentation and several new features such as Partial OT, Unbalanced and Multi Sources OT Domain Adaptation and several bug fixes. One important change is that we have created a the GitHub organization [PythonOT](https://github.com/PythonOT) that now owns the main POT repository [https://github.com/PythonOT/POT](https://github.com/PythonOT/POT) and the repository for the new documentation hosted at [https://PythonOT.github.io/](https://PythonOT.github.io/).
@@ -40,7 +40,7 @@ This release is also the moment to thank all the POT contributors (old and new)
- Log bugs for Gromov-Wassertein solver (Issue #107, fixed in PR #108)
- Weight issues in barycenter function (PR #106)
-## 0.6
+## 0.6.0
*July 2019*
This is the first official stable release of POT and this means a jump to 0.6!
diff --git a/docs/source/readme.rst b/docs/source/readme.rst
index c96f191..add0c00 100644
--- a/docs/source/readme.rst
+++ b/docs/source/readme.rst
@@ -121,7 +121,7 @@ The library has been tested on Linux, MacOSX and Windows. It requires a
C++ compiler for building/installing the EMD solver and relies on the
following Python modules:
-- Numpy (>=1.11)
+- Numpy (>=1.16)
- Scipy (>=1.0)
- Cython (>=0.23)
- Matplotlib (>=1.5)
diff --git a/docs/source/releases.rst b/docs/source/releases.rst
index 075108f..2bba432 100644
--- a/docs/source/releases.rst
+++ b/docs/source/releases.rst
@@ -1,8 +1,89 @@
Releases
========
-0.6
----
+0.7.0
+-----
+
+*May 2020*
+
+This is the new stable release for POT. We have a lot of changes in the
+documentation and several new features such as Partial OT, Unbalanced
+and Multi Sources OT Domain Adaptation and several bug fixes. One
+important change is that we have created a the GitHub organization
+`PythonOT <https://github.com/PythonOT>`__ that now owns the main POT
+repository https://github.com/PythonOT/POT and the repository for the
+new documentation hosted at https://PythonOT.github.io/.
+
+This is the first release where the Python 2.7 tests have been removed.
+Most of the toolbox should still work but we do not offer support for
+Python 2.7 and will close related Issues.
+
+A lot of changes have been done to the documentation that is now hosted
+on https://PythonOT.github.io/ instead of readthedocs. It was a hard
+choice but readthedocs did not allow us to run sphinx-gallery to update
+our beautiful examples and it was a huge amount of work to maintain it.
+The documentation is now automatically compiled and updated on merge. We
+also removed the notebooks from the repository for space reason and also
+because they are all available in the `example
+gallery <auto_examples/index.html>`__. Note
+that now the output of the documentation build for each commit in the PR
+is available to check that the doc builds correctly before merging which
+was not possible with readthedoc.
+
+The CI framework has also been changed with a move from Travis to Github
+Action which allows us to get faster tests on Windows, MacOS and Linux.
+We also now report our coverage on
+`Codecov.io <https://codecov.io/gh/PythonOT/POT>`__ and we have a
+reasonable 92% coverage. We also now generate wheels for a number of OS
+and python versions at each merge in the master branch. They are
+available as artifacts of this
+`action <https://github.com/PythonOT/POT/actions?query=workflow%3A%22Build+dist+and+wheels%22>`__.
+This will allow simpler multi-platform releases from now on.
+
+In terms of new features we now have `OTDA Classes for unbalanced
+OT <https://pythonot.github.io/gen_modules/ot.da.html#ot.da.UnbalancedSinkhornTransport>`__,
+a new Domain adaptation class form `multi domain problems
+(JCPOT) <auto_examples/domain-adaptation/plot_otda_jcpot.html#sphx-glr-auto-examples-domain-adaptation-plot-otda-jcpot-py>`__,
+and several solvers to solve the `Partial Optimal
+Transport <auto_examples/unbalanced-partial/plot_partial_wass_and_gromov.html#sphx-glr-auto-examples-unbalanced-partial-plot-partial-wass-and-gromov-py>`__
+problems.
+
+This release is also the moment to thank all the POT contributors (old
+and new) for helping making POT such a nice to use toolbox. A lot of
+changes (also in the API) are comming for the next versions.
+
+Features
+^^^^^^^^
+
+- New documentation on https://PythonOT.github.io/ (PR #160, PR #143,
+ PR #144)
+- Documentation build on CircleCI with sphinx-gallery (PR #145,PR #146,
+ #155)
+- Run sphinx gallery in CI (PR #146)
+- Remove notebooks from repo because available in doc (PR #156)
+- Build wheels in CI (#157)
+- Move from travis to GitHub Action for Windows, MacOS and Linux (PR
+ #148, PR #150)
+- Partial Optimal Transport (PR#141 and PR #142)
+- Laplace regularized OTDA (PR #140)
+- Multi source DA with target shift (PR #137)
+- Screenkhorn algorithm (PR #121)
+
+Closed issues
+^^^^^^^^^^^^^
+
+- Bug in Unbalanced OT example (Issue #127)
+- Clean Cython output when calling setup.py clean (Issue #122)
+- Various Macosx compilation problems (Issue #113, Issue #118, PR#130)
+- EMD dimension mismatch (Issue #114, Fixed in PR #116)
+- 2D barycenter bug for non square images (Issue #124, fixed in PR
+ #132)
+- Bad value in EMD 1D (Issue #138, fixed in PR #139)
+- Log bugs for Gromov-Wassertein solver (Issue #107, fixed in PR #108)
+- Weight issues in barycenter function (PR #106)
+
+0.6.0
+-----
*July 2019*