summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2021-12-31 14:29:33 +0100
committerGard Spreemann <gspr@nonempty.org>2021-12-31 14:29:33 +0100
commitc4753bd3f74139af8380127b66b484bc09b50661 (patch)
tree43ce043357f0b33c0dc9279e4f9050aeafe81215
parentedab1c60630f95b38db430017585d06253c92817 (diff)
parentbe0ed1dcd0b65ec804e454f1a2d3c0d227c0ddbe (diff)
Merge tag '0.8.1.0' into dfsg/latest
-rw-r--r--.circleci/config.yml7
-rw-r--r--RELEASES.md12
-rw-r--r--examples/backends/plot_optim_gromov_pytorch.py9
-rw-r--r--ot/__init__.py2
-rw-r--r--setup.py2
5 files changed, 24 insertions, 8 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index 32c211f..f5cb756 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -161,7 +161,10 @@ workflows:
default:
jobs:
- - build_docs
+ - build_docs:
+ filters:
+ tags:
+ only: /[0-9]+(\.[0-9]+)*$/
- deploy_master:
requires:
- build_docs
@@ -170,6 +173,8 @@ workflows:
only:
- master
- deploy_tag:
+ requires:
+ - build_docs
filters:
branches:
ignore: /.*/
diff --git a/RELEASES.md b/RELEASES.md
index 2a45465..00af0fb 100644
--- a/RELEASES.md
+++ b/RELEASES.md
@@ -1,6 +1,18 @@
# Releases
+## 0.8.1.0
+*December 2021*
+
+This is a bug fix release that will remove the `benchmarks` module form the
+installation and correct the documentation generation.
+
+#### Closed issues
+
+- Bug in documentation generation (tag VS master push, PR #332)
+- Remove installation of the benchmarks in global namespace (Issue #331, PR #333)
+
+
## 0.8.1
*December 2021*
diff --git a/examples/backends/plot_optim_gromov_pytorch.py b/examples/backends/plot_optim_gromov_pytorch.py
index 969707f..cdc1587 100644
--- a/examples/backends/plot_optim_gromov_pytorch.py
+++ b/examples/backends/plot_optim_gromov_pytorch.py
@@ -3,15 +3,15 @@ r"""
Optimizing the Gromov-Wasserstein distance with PyTorch
=================================
-In this exemple we use the pytorch backend to optimize the Gromov-Wasserstein
+In this example, we use the pytorch backend to optimize the Gromov-Wasserstein
(GW) loss between two graphs expressed as empirical distribution.
-In the first example we optimize the weights on the node of a simple template
+In the first part, we optimize the weights on the node of a simple template
graph so that it minimizes the GW with a given Stochastic Block Model graph.
We can see that this actually recovers the proportion of classes in the SBM
and allows for an accurate clustering of the nodes using the GW optimal plan.
-In a second example we optimize simultaneously the weights and the sructure of
+In the second part, we optimize simultaneously the weights and the sructure of
the template graph which allows us to perform graph compression and to recover
other properties of the SBM.
@@ -186,8 +186,7 @@ pl.axis("off")
# %%
# Graph compression with GW
# -------------------------
-
-# Now we optimize both the weights and structure of a small graph that
+# Now we optimize both the weights and structure of a small graph that
# minimize the GW distance wrt our data graph. This can be seen as graph
# compression but can also recover important properties of an SBM such
# as its class proportion but also its matrix of probability of links between
diff --git a/ot/__init__.py b/ot/__init__.py
index e436571..f55819d 100644
--- a/ot/__init__.py
+++ b/ot/__init__.py
@@ -50,7 +50,7 @@ from .gromov import (gromov_wasserstein, gromov_wasserstein2,
# utils functions
from .utils import dist, unif, tic, toc, toq
-__version__ = "0.8.1"
+__version__ = "0.8.1.0"
__all__ = ['emd', 'emd2', 'emd_1d', 'sinkhorn', 'sinkhorn2', 'utils',
'datasets', 'bregman', 'lp', 'tic', 'toc', 'toq', 'gromov',
diff --git a/setup.py b/setup.py
index 17bf968..d46ae1c 100644
--- a/setup.py
+++ b/setup.py
@@ -54,7 +54,7 @@ setup(
author=u'Remi Flamary, Nicolas Courty',
author_email='remi.flamary@gmail.com, ncourty@gmail.com',
url='https://github.com/PythonOT/POT',
- packages=find_packages(),
+ packages=find_packages(exclude=["benchmarks"]),
ext_modules=cythonize(Extension(
name="ot.lp.emd_wrap",
sources=["ot/lp/emd_wrap.pyx", "ot/lp/EMD_wrapper.cpp"], # cython/c++ src files