summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2021-10-27 10:17:08 +0200
committerGitHub <noreply@github.com>2021-10-27 10:17:08 +0200
commit81db2e7e3c537572cbec0049d8f125b0bdba6393 (patch)
tree922cc1d2eba65bc8344a45fbf3845414351df24b
parentd7554331fc409fea48ee758fd630909dd9dc4827 (diff)
[WIP] POT build without installing cython first (#293)
* test build with no dep * cleaning up stuff * build wheels
-rw-r--r--.circleci/config.yml3
-rw-r--r--.github/workflows/build_tests.yml19
-rw-r--r--README.md8
-rw-r--r--pyproject.toml3
4 files changed, 15 insertions, 18 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index 379394a..f13aaa0 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -38,10 +38,11 @@ jobs:
name: Get Python running
command: |
python -m pip install --user --upgrade --progress-bar off pip
+ python -m pip install --user -e .
python -m pip install --user --upgrade --progress-bar off -r requirements.txt
python -m pip install --user --upgrade --progress-bar off -r docs/requirements.txt
python -m pip install --user --upgrade --progress-bar off ipython "https://api.github.com/repos/sphinx-gallery/sphinx-gallery/zipball/master" memory_profiler
- python -m pip install --user -e .
+
- save_cache:
key: pip-cache
diff --git a/.github/workflows/build_tests.yml b/.github/workflows/build_tests.yml
index fd0ade6..91631b4 100644
--- a/.github/workflows/build_tests.yml
+++ b/.github/workflows/build_tests.yml
@@ -30,14 +30,14 @@ jobs:
uses: actions/setup-python@v1
with:
python-version: ${{ matrix.python-version }}
+ - name: Install POT
+ run: |
+ pip install -e .
- name: Install dependencies
run: |
python -m pip install --upgrade pip
pip install -r requirements.txt
pip install pytest "pytest-cov<2.6" codecov
- - name: Install POT
- run: |
- pip install -e .
- name: Run tests
run: |
python -m pytest --durations=20 -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot --color=yes
@@ -88,7 +88,6 @@ jobs:
- name: Install dependencies
run: |
python -m pip install --upgrade pip
- pip install -r .github/requirements_strict.txt
pip install pytest
- name: Install POT
run: |
@@ -112,14 +111,14 @@ jobs:
uses: actions/setup-python@v1
with:
python-version: ${{ matrix.python-version }}
+ - name: Install POT
+ run: |
+ pip install -e .
- name: Install dependencies
run: |
python -m pip install --upgrade pip
pip install -r requirements.txt
pip install pytest "pytest-cov<2.6"
- - name: Install POT
- run: |
- pip install -e .
- name: Run tests
run: |
python -m pytest --durations=20 -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot --color=yes
@@ -139,15 +138,15 @@ jobs:
uses: actions/setup-python@v1
with:
python-version: ${{ matrix.python-version }}
+ - name: Install POT
+ run: |
+ python -m pip install -e .
- name: Install dependencies
run: |
python -m pip install --upgrade pip
python -m pip install -r .github/requirements_test_windows.txt
python -m pip install torch==1.8.1+cpu -f https://download.pytorch.org/whl/torch_stable.html
python -m pip install pytest "pytest-cov<2.6"
- - name: Install POT
- run: |
- python -m pip install -e .
- name: Run tests
run: |
python -m pytest --durations=20 -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot --color=yes
diff --git a/README.md b/README.md
index ffad0bd..f0e5227 100644
--- a/README.md
+++ b/README.md
@@ -79,16 +79,10 @@ The library has been tested on Linux, MacOSX and Windows. It requires a C++ comp
- Numpy (>=1.16)
- Scipy (>=1.0)
-- Cython (>=0.23) (build only, not necessary when installing wheels from pip or conda)
+- Cython (>=0.23) (build only, not necessary when installing from pip or conda)
#### Pip installation
-Note that due to a limitation of pip, `cython` and `numpy` need to be installed
-prior to installing POT. This can be done easily with
-
-```console
-pip install numpy cython
-```
You can install the toolbox through PyPI with:
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..3f8ae8b
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools", "wheel", "numpy>=1.16", "cython>=0.23"]
+build-backend = "setuptools.build_meta" \ No newline at end of file