summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2021-12-26 22:27:18 +0100
committerGitHub <noreply@github.com>2021-12-26 22:27:18 +0100
commit176c6b4a72e06233f6e238e4a80c94b853a0d493 (patch)
tree966820344b24a64b5905e543fb733e5bb8aeb4c2
parentde5abace7dbff576e92b14319b845b70db469309 (diff)
[MRG] Release 0.8.1 (#325)
* update delease file and add it to doc ith mystè_parser * typos in release file * update PR template * test debug doc build * test debug doc build * wrog circleci * set proper version number * add numpy 1.20 constraint * remove python 3.6 deprecated in december * add python 3.10 * debug pip on windows * proper yml * remoe 3.10 becauqe of troch * next try * try distutils * back * try something * new stuf * debug yaml * test back to old vriso f numpy * try something * windows is worksing?
-rw-r--r--.github/workflows/build_tests.yml21
-rw-r--r--RELEASES.md16
-rw-r--r--ot/__init__.py2
-rw-r--r--requirements.txt2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py1
6 files changed, 32 insertions, 12 deletions
diff --git a/.github/workflows/build_tests.yml b/.github/workflows/build_tests.yml
index ee5a435..3c99da8 100644
--- a/.github/workflows/build_tests.yml
+++ b/.github/workflows/build_tests.yml
@@ -22,7 +22,7 @@ jobs:
strategy:
max-parallel: 4
matrix:
- python-version: [ "3.6", "3.7", "3.8", "3.9"]
+ python-version: ["3.7", "3.8", "3.9"]
steps:
- uses: actions/checkout@v1
@@ -128,12 +128,29 @@ jobs:
uses: actions/setup-python@v1
with:
python-version: ${{ matrix.python-version }}
+ - name: RC.exe
+ run: |
+ function Invoke-VSDevEnvironment {
+ $vswhere = "${env:ProgramFiles(x86)}\Microsoft Visual Studio\Installer\vswhere.exe"
+ $installationPath = & $vswhere -prerelease -legacy -latest -property installationPath
+ $Command = Join-Path $installationPath "Common7\Tools\vsdevcmd.bat"
+ & "${env:COMSPEC}" /s /c "`"$Command`" -no_logo && set" | Foreach-Object {
+ if ($_ -match '^([^=]+)=(.*)') {
+ [System.Environment]::SetEnvironmentVariable($matches[1], $matches[2])
+ }
+ }
+ }
+ Invoke-VSDevEnvironment
+ Get-Command rc.exe | Format-Table -AutoSize
+ - name: Update pip
+ run : |
+ python -m pip install --upgrade pip setuptools
+ python -m pip install cython
- name: Install POT
run: |
python -m pip install -e .
- name: Install dependencies
run: |
- python -m pip install --upgrade pip
python -m pip install -r .github/requirements_test_windows.txt
python -m pip install torch==1.8.1+cpu -f https://download.pytorch.org/whl/torch_stable.html
python -m pip install pytest "pytest-cov<2.6"
diff --git a/RELEASES.md b/RELEASES.md
index 6d4f565..ff65fc1 100644
--- a/RELEASES.md
+++ b/RELEASES.md
@@ -1,16 +1,18 @@
# Releases
-## 0.8.1dev
+## 0.8.1
*December 2021*
-This release fixes several bugs and introduce two new backends: Cupy
-and Tensorflow. Note that teh tensorflow backend will work only when tensorflow
-has enabled the Numpy behavior (that's for transpose that is not by default in
-tensorflow). We also introduce a simple benchmark on CPU GPU for te sinkhorn
-solver that will be provided in teh documentation.
+This release fixes several bugs and introduces two new backends: Cupy
+and Tensorflow. Note that the tensorflow backend will work only when tensorflow
+has enabled the Numpy behavior (for transpose that is not by default in
+tensorflow). We also introduce a simple benchmark on CPU GPU for the sinkhorn
+solver that will be provided in the
+[backend](https://pythonot.github.io/gen_modules/ot.backend.html) documentation.
-As always we want to that the contributors who helped mak POT better (and bug free).
+
+As always we want to that the contributors who helped make POT better (and bug free).
#### New features
diff --git a/ot/__init__.py b/ot/__init__.py
index 55972ea..e436571 100644
--- a/ot/__init__.py
+++ b/ot/__init__.py
@@ -50,7 +50,7 @@ from .gromov import (gromov_wasserstein, gromov_wasserstein2,
# utils functions
from .utils import dist, unif, tic, toc, toq
-__version__ = "0.8.1dev"
+__version__ = "0.8.1"
__all__ = ['emd', 'emd2', 'emd_1d', 'sinkhorn', 'sinkhorn2', 'utils',
'datasets', 'bregman', 'lp', 'tic', 'toc', 'toq', 'gromov',
diff --git a/requirements.txt b/requirements.txt
index d43be7a..8b75241 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,4 +1,4 @@
-numpy
+numpy>=1.16
scipy>=1.3
cython
matplotlib
diff --git a/setup.cfg b/setup.cfg
index 1177faf..9a4c434 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[metadata]
-description-file = README.md
+description_file = README.md
[flake8]
exclude = __init__.py
diff --git a/setup.py b/setup.py
index 86c7c8d..44cc6dd 100644
--- a/setup.py
+++ b/setup.py
@@ -95,5 +95,6 @@ setup(
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
]
)