summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2017-04-21 09:08:38 +0200
committerRémi Flamary <remi.flamary@gmail.com>2017-04-21 09:08:38 +0200
commitb33146062f847edd7c535a78535eae47058ba8fe (patch)
treea71ab3592862029aa0f01e0b30eed965806b2384
parentad693e32e78df399ccaea07402613813a6c4d8db (diff)
small normalization bug
-rw-r--r--README.md2
-rw-r--r--ot/da.py2
2 files changed, 3 insertions, 1 deletions
diff --git a/README.md b/README.md
index 53faac7..46c3649 100644
--- a/README.md
+++ b/README.md
@@ -68,6 +68,8 @@ cd cudamat
python setup.py install --user # for user install (no root)
```
+obviously you need CUDA installed and a compatible GPU.
+
## Examples
The examples folder contain several examples and use case for the library. The full documentation is available on [Readthedocs](http://pot.readthedocs.io/)
diff --git a/ot/da.py b/ot/da.py
index d607e50..44ce829 100644
--- a/ot/da.py
+++ b/ot/da.py
@@ -620,7 +620,7 @@ class OTDA(object):
self.wt=wt
self.M=dist(xs,xt,metric=self.metric)
- self.normalize()
+ self.normalizeM(norm)
self.G=emd(ws,wt,self.M)
self.computed=True