summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Courty <ncourty@irisa.fr>2018-05-29 15:10:18 +0200
committerGitHub <noreply@github.com>2018-05-29 15:10:18 +0200
commitec79b791f4f4a62f7c04b7bbf14fe2f5dcbb4c75 (patch)
treef1d991133db4dbaafaaf60853ace166360ab7353
parent27032b6fa0f2f68af3fe4f90e5dcbb68f130a962 (diff)
parentcc981610ba88e0222246aec2fdff903e8b83d918 (diff)
Merge pull request #46 from rflamary/build_macosx
Add Python 3.5 and 3.6 and remove macosx on travis
-rw-r--r--.travis.yml16
-rwxr-xr-x.travis/before_install.sh3
-rw-r--r--Makefile2
-rw-r--r--requirements.txt1
4 files changed, 14 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index ec2b3d2..d146395 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,15 +1,21 @@
language: python
matrix:
- allow_failures:
- - os: osx
+# allow_failures:
+# - os: osx
include:
- - os: osx
- language: generic
+# - os: osx
+# language: generic
- os: linux
sudo: required
python: 3.4
- os: linux
sudo: required
+ python: 3.5
+ - os: linux
+ sudo: required
+ python: 3.6
+ - os: linux
+ sudo: required
python: 2.7
before_install:
- ./.travis/before_install.sh
@@ -26,5 +32,5 @@ install:
script:
- python setup.py develop
- flake8 examples/ ot/ test/
- - python -m py.test -v test/
+ - python -m pytest -v test/
# - py.test ot test
diff --git a/.travis/before_install.sh b/.travis/before_install.sh
index 60d1dcf..0ae6249 100755
--- a/.travis/before_install.sh
+++ b/.travis/before_install.sh
@@ -6,8 +6,7 @@ if [[ $TRAVIS_OS_NAME == 'osx' ]]; then
# e.g. brew install pyenv-virtualenv
#brew update
#brew install python
- echo do othing
-
+ sudo easy_install -U pip
else
# Install some custom requirements on Linux
diff --git a/Makefile b/Makefile
index 95714b8..0de3fe9 100644
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,7 @@ test : FORCE pep8
$(PYTHON) -m pytest -v test/ --cov=ot --cov-report html:cov_html
pytest : FORCE
- $(PYTHON) -m py.test -v test/ --cov=ot
+ $(PYTHON) -m pytest -v test/ --cov=ot
uploadpypi :
#python setup.py register
diff --git a/requirements.txt b/requirements.txt
index 9bfca43..37d62cc 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -5,3 +5,4 @@ matplotlib
sphinx-gallery
autograd
pymanopt
+pytest