summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2019-07-05 10:27:40 +0200
committerRémi Flamary <remi.flamary@gmail.com>2019-07-05 10:27:40 +0200
commit17ba10e33a3eeb3a5a03af4dfb2cddc900bc1f2e (patch)
tree99ab694d72c5f480fd0ca9d026bbf6838f452f9b
parent852e330bfca616e033fa4453fcd77bd4f1af1a06 (diff)
clean manifest and add wheels build in Makefile
-rw-r--r--MANIFEST.in2
-rw-r--r--Makefile20
-rw-r--r--README.md2
-rwxr-xr-xsetup.py4
4 files changed, 16 insertions, 12 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index e0acb7a..df4e139 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,5 +1,5 @@
-graft ot/lp/
include README.md
+include RELEASES.md
include LICENSE
include ot/lp/core.h
include ot/lp/EMD.h
diff --git a/Makefile b/Makefile
index bd3c1b4..729fd8c 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@
PYTHON=python3
branch := $(shell git symbolic-ref --short -q HEAD)
-CIBW_BEFORE_BUILD="pip install numpy cython"
+
help :
@@ -15,6 +15,7 @@ help :
@echo " sremove - remove the package (system with sudo)"
@echo " clean - remove any temporary files"
@echo " notebook - launch ipython notebook"
+
build :
$(PYTHON) setup.py build
@@ -49,14 +50,15 @@ test : FORCE pep8
pytest : FORCE
$(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/ --cov=ot
-uploadpypi :
- #python setup.py register
- $(PYTHON) setup.py sdist upload -r pypi
+release :
+ twine upload dist/*
+
+release_test :
+ twine upload --repository-url https://test.pypi.org/legacy/ dist/*
rdoc :
pandoc --from=markdown --to=rst --output=docs/source/readme.rst README.md
-
notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
@@ -76,7 +78,11 @@ autopep8 :
aautopep8 :
autopep8 -air test ot examples --jobs -1
-wheels:
- cibuildwheel --platform linux --output-dir dist
+wheels :
+ CIBW_BEFORE_BUILD="pip install numpy cython" cibuildwheel --platform linux --output-dir dist
+
+dist : wheels
+ $(PYTHON) setup.py sdist
+
FORCE :
diff --git a/README.md b/README.md
index 8cf798f..69a826a 100644
--- a/README.md
+++ b/README.md
@@ -166,8 +166,6 @@ This toolbox has been created and is maintained by
The contributors to this library are
-* [Rémi Flamary](http://remi.flamary.com/)
-* [Nicolas Courty](http://people.irisa.fr/Nicolas.Courty/)
* [Alexandre Gramfort](http://alexandre.gramfort.net/)
* [Laetitia Chapel](http://people.irisa.fr/Laetitia.Chapel/)
* [Michael Perrot](http://perso.univ-st-etienne.fr/pem82055/) (Mapping estimation)
diff --git a/setup.py b/setup.py
index bbcaf04..89b43d9 100755
--- a/setup.py
+++ b/setup.py
@@ -53,8 +53,8 @@ setup(name='POT',
license = 'MIT',
scripts=[],
data_files=[],
- requires=["numpy","scipy","cython","matplotlib"],
- install_requires=["numpy","scipy","cython","matplotlib"],
+ requires=["numpy","scipy","cython"],
+ install_requires=["numpy","scipy","cython"],
classifiers=[
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',