summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2018-05-09 14:15:48 +0200
committerRémi Flamary <remi.flamary@gmail.com>2018-05-09 14:15:48 +0200
commit4090857cfcda73d383e4cdbcc466fe326f06bd19 (patch)
tree92d3a328a1753f686daf31913e94b5ecc43ab363
parent58387b96cb2b4a417c84e729f0084be68fad731e (diff)
test install pip on macosx
-rwxr-xr-x.travis/before_install.sh5
-rw-r--r--Makefile2
2 files changed, 4 insertions, 3 deletions
diff --git a/.travis/before_install.sh b/.travis/before_install.sh
index ddaa142..0ae6249 100755
--- a/.travis/before_install.sh
+++ b/.travis/before_install.sh
@@ -4,8 +4,9 @@ if [[ $TRAVIS_OS_NAME == 'osx' ]]; then
# Install some custom requirements on OS X
# e.g. brew install pyenv-virtualenv
- brew update
- brew install python
+ #brew update
+ #brew install python
+ sudo easy_install -U pip
else
# Install some custom requirements on Linux
diff --git a/Makefile b/Makefile
index 95714b8..0de3fe9 100644
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,7 @@ test : FORCE pep8
$(PYTHON) -m pytest -v test/ --cov=ot --cov-report html:cov_html
pytest : FORCE
- $(PYTHON) -m py.test -v test/ --cov=ot
+ $(PYTHON) -m pytest -v test/ --cov=ot
uploadpypi :
#python setup.py register