summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2018-05-14 11:41:21 +0200
committerRémi Flamary <remi.flamary@gmail.com>2018-05-14 11:41:21 +0200
commit8ba983dea4a44fdf9946e4031db621815852394c (patch)
tree8c55e92929d6e8a94c62773f48f05d8103e8f90f
parentda8f6119484642eca6e8efb3e5aaecce7a777622 (diff)
update doc + speedup autopep8
-rw-r--r--Makefile4
-rw-r--r--examples/plot_barycenter_lp_vs_entropic.py9
2 files changed, 9 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 95714b8..5fa80e9 100644
--- a/Makefile
+++ b/Makefile
@@ -58,9 +58,9 @@ notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
autopep8 :
- autopep8 -ir test ot examples
+ autopep8 -ir test ot examples --jobs -1
aautopep8 :
- autopep8 -air test ot examples
+ autopep8 -air test ot examples --jobs -1
FORCE :
diff --git a/examples/plot_barycenter_lp_vs_entropic.py b/examples/plot_barycenter_lp_vs_entropic.py
index 2eded2f..3a65449 100644
--- a/examples/plot_barycenter_lp_vs_entropic.py
+++ b/examples/plot_barycenter_lp_vs_entropic.py
@@ -4,14 +4,19 @@
1D Wasserstein barycenter comparison between exact LP and entropic regularization
=================================================================================
-This example illustrates the computation of regularized Wassersyein Barycenter
-as proposed in [3].
+This example illustrates the computation of regularized Wasserstein Barycenter
+as proposed in [3] and exact LP barycenters using standard LP solver.
+It reproduces approximately Figure 3.1 and 3.2 from the following paper:
+Cuturi, M., & Peyré, G. (2016). A smoothed dual approach for variational
+Wasserstein problems. SIAM Journal on Imaging Sciences, 9(1), 320-343.
[3] Benamou, J. D., Carlier, G., Cuturi, M., Nenna, L., & Peyré, G. (2015).
Iterative Bregman projections for regularized transportation problems
SIAM Journal on Scientific Computing, 37(2), A1111-A1138.
+
+
"""
# Author: Remi Flamary <remi.flamary@unice.fr>