summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Gramfort <alexandre.gramfort@m4x.org>2017-07-11 21:32:41 +0200
committerAlexandre Gramfort <alexandre.gramfort@m4x.org>2017-07-20 14:05:12 +0200
commitd0258f103946eb78f2fff6a3a82d85744ba27ec8 (patch)
tree12d09dbb66038e82a41485826f1f0185a4b63080
parente5ff4ea3bff066a49ed9b69c1a15d27db28503be (diff)
add flake8 to travis + misc
-rw-r--r--.gitignore3
-rw-r--r--.travis.yml8
2 files changed, 9 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 21be4c9..6edce05 100644
--- a/.gitignore
+++ b/.gitignore
@@ -97,3 +97,6 @@ ENV/
# Rope project settings
.ropeproject
+
+# Mac stuff
+.DS_Store
diff --git a/.travis.yml b/.travis.yml
index 6126b3a..8023ec5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -16,6 +16,10 @@ before_install:
# command to install dependencies
install:
- pip install -r requirements.txt
+ - pip install flake8 pytest
- python setup.py install
-# command to run tests
-script: python test/test_load_module.py -v
+# command to run tests + check syntax style
+script:
+ - python test/test_load_module.py -v
+ - flake8 .
+ - py.test ot test