summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Gramfort <alexandre.gramfort@m4x.org>2020-04-21 17:40:32 +0200
committerAlexandre Gramfort <alexandre.gramfort@m4x.org>2020-04-21 17:40:32 +0200
commitf9638166521a1160838fae75e2a2e318d645460e (patch)
tree8b3f08cf68ce7c72ed1552fda1facf444fcda6da
parent0b2d808aaebb1cab60a272ea7901d5f77df43a9f (diff)
rm travis
-rw-r--r--.github/workflows/pythonpackage.yml8
-rw-r--r--.travis.yml50
-rwxr-xr-x.travis/before_install.sh15
-rw-r--r--README.md1
4 files changed, 3 insertions, 71 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index 19527c3..755937a 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -3,12 +3,10 @@ name: Test Package
on:
push:
branches:
- - '**'
- create:
+ - master
+ pull_request:
branches:
- - 'master'
- tags:
- - '**'
+ - master
jobs:
linux:
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 3f63867..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,50 +0,0 @@
-dist: xenial # required for Python >= 3.7
-language: python
-matrix:
- # allow_failures:
- # - os: osx
- # - os: windows
- include:
- - os: linux
- sudo: required
- python: 3.5
- - os: linux
- sudo: required
- python: 3.6
- - os: linux
- sudo: required
- python: 3.7
- - os: linux
- sudo: required
- python: 3.8
- # - os: osx
- # sudo: required
- # language: generic
- # - name: "Python 3.7.3 on Windows"
- # os: windows # Windows 10.0.17134 N/A Build 17134
- # language: shell # 'language: python' is an error on Travis CI Windows
- # before_install: choco install python
- # env: PATH=/c/Python37:/c/Python37/Scripts:$PATH
-# before_script: # configure a headless display to test plot generation
-# - "export DISPLAY=:99.0"
-# - sleep 3 # give xvfb some time to start
-before_install:
- - ./.travis/before_install.sh
-# command to install dependencies
-install:
- - pip install -r requirements.txt
- - pip install -U "numpy>=1.14" scipy # for numpy array formatting in doctests
- - pip install flake8 pytest "pytest-cov<2.6" codecov
- - pip install -U "sklearn"
- - pip install .
-# command to run tests + check syntax style
-services:
- - xvfb
-script:
- - python setup.py develop
- - flake8 examples/ ot/ test/
- - python -m pytest -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot
- # - py.test ot test
-after_script:
- # Need to run from source dir to execute "git" commands
- - codecov;
diff --git a/.travis/before_install.sh b/.travis/before_install.sh
deleted file mode 100755
index 0ae6249..0000000
--- a/.travis/before_install.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/bash
-
-if [[ $TRAVIS_OS_NAME == 'osx' ]]; then
-
- # Install some custom requirements on OS X
- # e.g. brew install pyenv-virtualenv
- #brew update
- #brew install python
- sudo easy_install -U pip
-
-else
- # Install some custom requirements on Linux
- sudo apt-get update -q
- sudo apt-get install libblas-dev liblapack-dev libatlas-base-dev
-fi
diff --git a/README.md b/README.md
index 65193ff..ca8481c 100644
--- a/README.md
+++ b/README.md
@@ -2,7 +2,6 @@
[![PyPI version](https://badge.fury.io/py/POT.svg)](https://badge.fury.io/py/POT)
[![Anaconda Cloud](https://anaconda.org/conda-forge/pot/badges/version.svg)](https://anaconda.org/conda-forge/pot)
-[![Build Status](https://travis-ci.org/PythonOT/POT.svg?branch=master)](https://travis-ci.org/PythonOT/POT)
[![Build Status](https://github.com/PythonOT/POT/workflows/Linux%7CWin%7CMacOS/badge.svg)](https://github.com/PythonOT/POT/actions)
[![Codecov Status](https://codecov.io/gh/PythonOT/POT/branch/master/graph/badge.svg)](https://codecov.io/gh/PythonOT/POT)
[![Documentation Status](https://readthedocs.org/projects/pot/badge/?version=latest)](http://pot.readthedocs.io/en/latest/?badge=latest)