summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorKilian <kilian.fatras@gmail.com>2018-08-29 14:22:40 -0700
committerGitHub <noreply@github.com>2018-08-29 14:22:40 -0700
commit15f4b29a91fda1dbd221e6e0a3443431d3d69257 (patch)
tree82c33ee8b09112b6a67ed614e370156e4144628f /Makefile
parent63b34bf012076eb89ed112122fdaa65667464ae7 (diff)
parent5180023fc49d15ad83faccc5674d5966fe9a0385 (diff)
Merge branch 'master' into stochastic_OT
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 1abc6e9..84a644b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
PYTHON=python3
+branch := $(shell git symbolic-ref --short -q HEAD)
help :
@echo "The following make targets are available:"
@@ -57,6 +58,16 @@ rdoc :
notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
+bench :
+ @git stash >/dev/null 2>&1
+ @echo 'Branch master'
+ @git checkout master >/dev/null 2>&1
+ python3 $(script)
+ @echo 'Branch $(branch)'
+ @git checkout $(branch) >/dev/null 2>&1
+ python3 $(script)
+ @git stash apply >/dev/null 2>&1
+
autopep8 :
autopep8 -ir test ot examples --jobs -1