summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2018-05-09 13:26:33 +0200
committerGitHub <noreply@github.com>2018-05-09 13:26:33 +0200
commit27032b6fa0f2f68af3fe4f90e5dcbb68f130a962 (patch)
treebef4b8a49cf410652e9c100274d010519acaf0f8 /Makefile
parent1ff35860db2d612748270299d7ce0037b8d40702 (diff)
parent0496e2b1b2c2f4ea2d7f313ccf58c612efaa70bf (diff)
Merge pull request #42 from rflamary/linear_mapping
Linear mapping + tests
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 3f19e8a..95714b8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
-PYTHON=python
+PYTHON=python3
help :
@echo "The following make targets are available:"
@@ -41,14 +41,14 @@ pep8 :
flake8 examples/ ot/ test/
test : FORCE pep8
- python -m py.test -v test/ --cov=ot --cov-report html:cov_html
+ $(PYTHON) -m pytest -v test/ --cov=ot --cov-report html:cov_html
pytest : FORCE
- python -m py.test -v test/ --cov=ot
+ $(PYTHON) -m py.test -v test/ --cov=ot
uploadpypi :
#python setup.py register
- python setup.py sdist upload -r pypi
+ $(PYTHON) setup.py sdist upload -r pypi
rdoc :
pandoc --from=markdown --to=rst --output=docs/source/readme.rst README.md
@@ -56,6 +56,11 @@ rdoc :
notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
+
+autopep8 :
+ autopep8 -ir test ot examples
+aautopep8 :
+ autopep8 -air test ot examples
FORCE :