summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2019-07-03 14:34:13 +0200
committerGitHub <noreply@github.com>2019-07-03 14:34:13 +0200
commit952503e02b1fc9bdf0811b937baacca57e4a98f1 (patch)
treec5b1b8f10eaee4c2ecaa12f629255489c2481590 /Makefile
parent8b3927bb5e8935c3dbddf054f054dc0c036fbdfe (diff)
parent7402d344240ce94e33c53daff419d4356278d48f (diff)
Merge pull request #88 from rflamary/doc_modules
[MRG] Update documentation and add quick start guide
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 84a644b..4cdb7d1 100644
--- a/Makefile
+++ b/Makefile
@@ -42,10 +42,10 @@ pep8 :
flake8 examples/ ot/ test/
test : FORCE pep8
- $(PYTHON) -m pytest -v test/ --cov=ot --cov-report html:cov_html
+ $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/ --cov=ot --cov-report html:cov_html
pytest : FORCE
- $(PYTHON) -m pytest -v test/ --cov=ot
+ $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/ --cov=ot
uploadpypi :
#python setup.py register