summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2017-07-24 11:15:33 +0200
committerRémi Flamary <remi.flamary@gmail.com>2017-07-24 11:15:33 +0200
commit5a6b5de9b2f28c93bef1a9db2e3b94693c05ff4f (patch)
tree1f7457a028ef71253be36c44fb87c2e4131e909a /Makefile
parent82da63f1020835a412f6174500099694a78ab6be (diff)
add proper testing
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index c6a83c8..ff03a63 100644
--- a/Makefile
+++ b/Makefile
@@ -31,22 +31,25 @@ sremove :
tr '\n' '\0' < files.txt | sudo xargs -0 rm -f --
rm files.txt
-clean :
+clean : FORCE
$(PYTHON) setup.py clean
pep8 :
flake8 examples/ ot/ test/
-test:
- pytest
+test : FORCE pep8
+ python -m py.test -v
-uploadpypi:
+uploadpypi :
#python setup.py register
python setup.py sdist upload -r pypi
-rdoc:
+rdoc :
pandoc --from=markdown --to=rst --output=docs/source/readme.rst README.md
notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
+
+
+FORCE :