summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2020-10-22 10:16:40 +0200
committerGitHub <noreply@github.com>2020-10-22 10:16:40 +0200
commit7adc1b1aa73c55dc07983ff08dcb23fd71e9e8b6 (patch)
tree701388c52a9accd727bb5b360897e0633b492f6a /Makefile
parent55164e9272c9899ca413fca411d410ec28b736b0 (diff)
[MRG] Cleanup minimal build and add separate build for pep8 (#210)
* cleanup requiorement minimal * add pep8 build * cleanup sklearn * skip test if no sklearn * debug build yaml * comment error out in test (test sklearn) * maybe small stuff for better robustness : copy the sub-array * bump verison minimal build * update version strict requireent * update version strict requirement last change
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 70cdbdd..32332b4 100644
--- a/Makefile
+++ b/Makefile
@@ -45,10 +45,10 @@ pep8 :
flake8 examples/ ot/ test/
test : FORCE pep8
- $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/ --cov=ot --cov-report html:cov_html
+ $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/
pytest : FORCE
- $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/ --cov=ot
+ $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/
release :
twine upload dist/*