summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2021-06-17 11:46:37 +0200
committerGitHub <noreply@github.com>2021-06-17 11:46:37 +0200
commit8ef3341a472909f223ec0f678f11f136f55c1406 (patch)
tree162cbd7f7a0e3bd87c2e3b5fe61f70f25ec951c5 /Makefile
parent2dbeeda9308029a8e8db56bed07d48f4d5718efb (diff)
[MRG] Speedup tests (#262)
* speedup tests * add color to tests and timings * add test unbalanced * stupid missing -
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 32332b4..315218d 100644
--- a/Makefile
+++ b/Makefile
@@ -45,10 +45,10 @@ pep8 :
flake8 examples/ ot/ test/
test : FORCE pep8
- $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/
+ $(PYTHON) -m pytest --durations=20 -v test/ --doctest-modules --ignore ot/gpu/
pytest : FORCE
- $(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/
+ $(PYTHON) -m pytest --durations=20 -v test/ --doctest-modules --ignore ot/gpu/
release :
twine upload dist/*