summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2018-07-24 14:40:21 +0200
committerRémi Flamary <remi.flamary@gmail.com>2018-07-24 14:40:21 +0200
commit581784c2b47f0844e0b8164cf5823937eb02d62f (patch)
tree646a71ec1eb229c8521e06aad66114dfe1cf8fd5 /Makefile
parent5e3392a029e675c7e19f8b1723fcfdb9aa9142aa (diff)
final makefile bench
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index dac8653..84a644b 100644
--- a/Makefile
+++ b/Makefile
@@ -59,12 +59,14 @@ notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
bench :
+ @git stash >/dev/null 2>&1
@echo 'Branch master'
- git checkout master
+ @git checkout master >/dev/null 2>&1
python3 $(script)
@echo 'Branch $(branch)'
- git checkout $(branch)
+ @git checkout $(branch) >/dev/null 2>&1
python3 $(script)
+ @git stash apply >/dev/null 2>&1
autopep8 :
autopep8 -ir test ot examples --jobs -1