summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2019-07-05 09:43:37 +0200
committerRémi Flamary <remi.flamary@gmail.com>2019-07-05 09:43:37 +0200
commit852e330bfca616e033fa4453fcd77bd4f1af1a06 (patch)
treebfd4f1b933224f39f255904744c76808e0ede36f /Makefile
parent952503e02b1fc9bdf0811b937baacca57e4a98f1 (diff)
prepare for version 1.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4cdb7d1..bd3c1b4 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,8 @@
PYTHON=python3
branch := $(shell git symbolic-ref --short -q HEAD)
+CIBW_BEFORE_BUILD="pip install numpy cython"
+
help :
@echo "The following make targets are available:"
@@ -73,5 +75,8 @@ autopep8 :
aautopep8 :
autopep8 -air test ot examples --jobs -1
+
+wheels:
+ cibuildwheel --platform linux --output-dir dist
FORCE :