summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2018-09-28 09:41:22 +0200
committerRémi Flamary <remi.flamary@gmail.com>2018-09-28 09:41:22 +0200
commitee8ed4fa101861eec9e578f09aee4367af593af1 (patch)
tree1996b7edaafe5f671a5275a37d6fd5cf7bf2051a /README.md
parent5e7bfbcbc99ce5915873147677b434c0b1d10fc8 (diff)
update documentation
Diffstat (limited to 'README.md')
-rw-r--r--README.md10
1 files changed, 3 insertions, 7 deletions
diff --git a/README.md b/README.md
index 5f37ad6..e49c8da 100644
--- a/README.md
+++ b/README.md
@@ -14,7 +14,7 @@ This open source Python library provide several solvers for optimization problem
It provides the following solvers:
* OT Network Flow solver for the linear program/ Earth Movers Distance [1].
-* Entropic regularization OT solver with Sinkhorn Knopp Algorithm [2] and stabilized version [9][10] with optional GPU implementation (requires cudamat).
+* Entropic regularization OT solver with Sinkhorn Knopp Algorithm [2] and stabilized version [9][10] with optional GPU implementation (requires cupy).
* Smooth optimal transport solvers (dual and semi-dual) for KL and squared L2 regularizations [17].
* Non regularized Wasserstein barycenters [16] with LP solver (only small scale).
* Bregman projections for Wasserstein barycenter [3] and unmixing [4].
@@ -83,12 +83,8 @@ Some sub-modules require additional dependences which are discussed below
```
pip install pymanopt autograd
```
-* **ot.gpu** (GPU accelerated OT) depends on cudamat that have to be installed with:
-```
-git clone https://github.com/cudamat/cudamat.git
-cd cudamat
-python setup.py install --user # for user install (no root)
-```
+* **ot.gpu** (GPU accelerated OT) depends on cupy that have to be installed following instructions on [this page](https://docs-cupy.chainer.org/en/stable/install.html).
+
obviously you need CUDA installed and a compatible GPU.