summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorDougal J. Sutherland <dougal@gmail.com>2017-07-20 12:12:13 +0100
committerGitHub <noreply@github.com>2017-07-20 12:12:13 +0100
commit0e20886a48b8d99e437bc26f1c39fde1d9ad433f (patch)
tree1b0ce736c9fc7e41803302bc81048ef80c7f166b /README.md
parente5ff4ea3bff066a49ed9b69c1a15d27db28503be (diff)
add conda-forge to installation instructions
Now that POT is in conda-forge (https://github.com/conda-forge/staged-recipes/pull/3332 / https://github.com/conda-forge/pot-feedstock/), might as well put that in the installation instructions. Note that it's available on Windows too, and [this basic test](https://github.com/conda-forge/pot-feedstock/blob/master/recipe/run_test.py) at least runs.
Diffstat (limited to 'README.md')
-rw-r--r--README.md17
1 files changed, 10 insertions, 7 deletions
diff --git a/README.md b/README.md
index d53387b..1f4c307 100644
--- a/README.md
+++ b/README.md
@@ -22,28 +22,31 @@ Some demonstrations (both in Python and Jupyter Notebook format) are available i
## Installation
-The Library has been tested on Linux and MacOSX. It requires a C++ compiler for using the EMD solver and rely on the following Python modules:
+The library has been tested on Linux and MacOSX. It requires a C++ compiler for using the EMD solver and relies on the following Python modules:
- Numpy (>=1.11)
- Scipy (>=0.17)
- Cython (>=0.23)
- Matplotlib (>=1.5)
-
-Under debian based linux the dependencies can be installed with
+If you use the Anaconda python distribution, POT is available in [conda-forge](conda-forge.github.io). To install it and the required dependencies:
```
-sudo apt-get install python-numpy python-scipy python-matplotlib cython
+conda install -c conda-forge pot
```
-To install the library, you can install it locally (after downloading it) on you machine using
+Otherwise, under Debian-based Linux the dependencies can be installed with:
```
-python setup.py install --user # for user install (no root)
+sudo apt-get install python-numpy python-scipy python-matplotlib cython
```
-The toolbox is also available on PyPI with a possibly slightly older version. You can install it with:
+You can then install the toolbox through PyPI with:
```
pip install POT
```
+or get the very latest version by downloading it and then running:
+```
+python setup.py install --user # for user install (no root)
+```
After a correct installation, you should be able to import the module without errors:
```python