summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2017-04-20 15:40:08 +0200
committerRémi Flamary <remi.flamary@gmail.com>2017-04-20 15:40:08 +0200
commitdabb16cd6601b92c5d6b8854c361ccf7343d96af (patch)
tree5d88787752d4de6e7b9e9522f25ff8a2d58d2345 /README.md
parent44b8462d94d37ae7fbe021b4097ef32d13a82e19 (diff)
add dependencies discussion in readme
Diffstat (limited to 'README.md')
-rw-r--r--README.md22
1 files changed, 19 insertions, 3 deletions
diff --git a/README.md b/README.md
index 3d944db..33ff301 100644
--- a/README.md
+++ b/README.md
@@ -37,7 +37,7 @@ sudo apt-get install python-numpy python-scipy python-matplotlib cython
To install the library, you can install it locally (after downloading it) on you machine using
```
-python setup.py install --user
+python setup.py install --user # for user install (no root)
```
The toolbox is also available on PyPI with a possibly slightly older version. You can install it with:
@@ -52,6 +52,22 @@ import ot
Note that for easier access the module is name ot instead of pot.
+
+### Dependencies
+
+Some sub-modules require additional dependences which are discussed below
+
+* ot.dr (Wasserstein dimensionality rediuction) depends on autograd and pymanopt that can be installed with:
+```
+pip install pymanopt autograd
+```
+* ot.gpu (GPU accelerated OT) depends on cudamat that have to be installed with:
+```
+git clone https://github.com/cudamat/cudamat.git
+cd cudamat
+python setup.py install --user # for user install (no root)
+```
+
## Examples
The examples folder contain several examples and use case for the library. The full documentation is available on [Readthedocs](http://pot.readthedocs.io/)
@@ -77,8 +93,8 @@ The contributors to this library are:
* [Rémi Flamary](http://remi.flamary.com/)
* [Nicolas Courty](http://people.irisa.fr/Nicolas.Courty/)
* [Laetitia Chapel](http://people.irisa.fr/Laetitia.Chapel/)
-* [Michael Perrot](http://perso.univ-st-etienne.fr/pem82055/)
-* [Léo Gautheron](https://github.com/aje)
+* [Michael Perrot](http://perso.univ-st-etienne.fr/pem82055/) (Mapping estimation)
+* [Léo Gautheron](https://github.com/aje) (GPU implementation)
This toolbox benefit a lot from open source research and we would like to thank the following persons for providing some code (in various languages):