summaryrefslogtreecommitdiff
path: root/examples/plot_optim_OTreg.py
diff options
context:
space:
mode:
authorRomain Tavenard <romain.tavenard@univ-rennes2.fr>2020-05-04 11:19:35 +0200
committerGitHub <noreply@github.com>2020-05-04 11:19:35 +0200
commite65c1f745cf2eacc6672727e7a3869efd8318768 (patch)
tree71590cd404f31806a5a99f0cf8faa8d9dca6b42e /examples/plot_optim_OTreg.py
parent98d6cdcfa3a24ba07b9b4428250b7aee7e62f1ea (diff)
[WIP] Improved docs and changed scipy version (#163)
* Improved docs and changed scipy version * Fixed dependency bug in setup.py * dependencies set to minimal versions for tests * add requirements file * added minimal version build for scipy (testing 1.2) * bugfix in minimal deps build * (yet another) bugfix in minimal deps build * minimal deps now reflect README.md * minimal deps: no autograd nor pymanopt * refactored workflow names * minimal deps: no doctests * minimal deps: numpy 1.16 * trigger GH Actions on PR * better merge * re-add minimal-deps... * bugfix in yaml * enforce np>=1.16 * enforce scipy and cython versions too * requires / install_requires * requires / install_requires / requires * setup_requires Co-authored-by: Rémi Flamary <remi.flamary@gmail.com>
Diffstat (limited to 'examples/plot_optim_OTreg.py')
-rw-r--r--examples/plot_optim_OTreg.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/plot_optim_OTreg.py b/examples/plot_optim_OTreg.py
index 51e2fdc..5eb15bd 100644
--- a/examples/plot_optim_OTreg.py
+++ b/examples/plot_optim_OTreg.py
@@ -6,7 +6,7 @@ Regularized OT with generic solver
Illustrates the use of the generic solver for regularized OT with
user-designed regularization term. It uses Conditional gradient as in [6] and
-generalized Conditional Gradient as proposed in [5][7].
+generalized Conditional Gradient as proposed in [5,7].
[5] N. Courty; R. Flamary; D. Tuia; A. Rakotomamonjy, Optimal Transport for
@@ -14,8 +14,8 @@ Domain Adaptation, in IEEE Transactions on Pattern Analysis and Machine
Intelligence , vol.PP, no.99, pp.1-1.
[6] Ferradans, S., Papadakis, N., Peyré, G., & Aujol, J. F. (2014).
-Regularized discrete optimal transport. SIAM Journal on Imaging Sciences,
-7(3), 1853-1882.
+Regularized discrete optimal transport. SIAM Journal on Imaging
+Sciences, 7(3), 1853-1882.
[7] Rakotomamonjy, A., Flamary, R., & Courty, N. (2015). Generalized
conditional gradient: analysis of convergence and applications.