summaryrefslogtreecommitdiff
path: root/ot/gpu/__init__.py
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2021-11-05 17:13:14 +0100
committerGitHub <noreply@github.com>2021-11-05 17:13:14 +0100
commitcec41d3817067a2eb3031092735347efe4184237 (patch)
treee5af7c2e72fd6f50590b2dd1c5f1f6f47dceebc3 /ot/gpu/__init__.py
parent0eac835c70cc1a13bb998f3b6cdb0515fafc05e1 (diff)
[MRG] Release 0.8 (#289)
* working on release * test circleci * try again * cleanup circle ci run * add all PR and releant Issues * update doc * thanks idris * update version + add pyproject.toml * test pyproject.toml * revert tests * build wheels * use windows-latest for tests * add tests python 3.10 * build all whels * all versions * build all wheels * build all wheels * cleanup pep8 and minimal acions * forst shot text release * bettr text * stuff * release text updated * update manifest to allow build from source * update doc again * update release
Diffstat (limited to 'ot/gpu/__init__.py')
-rw-r--r--ot/gpu/__init__.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/ot/gpu/__init__.py b/ot/gpu/__init__.py
index e939610..12db605 100644
--- a/ot/gpu/__init__.py
+++ b/ot/gpu/__init__.py
@@ -7,7 +7,13 @@ The GPU backend in handled by `cupy
<https://cupy.chainer.org/>`_.
.. warning::
- Note that by default the module is not import in :mod:`ot`. In order to
+ This module is now deprecated and will be removed in future releases. POT
+ now privides a backend mechanism that allows for solving prolem on GPU wth
+ the pytorch backend.
+
+
+.. warning::
+ Note that by default the module is not imported in :mod:`ot`. In order to
use it you need to explicitely import :mod:`ot.gpu` .
By default, the functions in this module accept and return numpy arrays
@@ -36,7 +42,7 @@ from . import utils
from .utils import dist, to_gpu, to_np
-warnings.warn('This module will be deprecated in the next minor release of POT', category=DeprecationWarning)
+warnings.warn('This module is deprecated and will be removed in the next minor release of POT', category=DeprecationWarning)
__all__ = ["utils", "dist", "sinkhorn",